summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/SchemaObject/SchemaObject-0.5.3.ebuild6
-rw-r--r--dev-python/cvxopt/cvxopt-1.1.6-r2.ebuild8
2 files changed, 10 insertions, 4 deletions
diff --git a/dev-python/SchemaObject/SchemaObject-0.5.3.ebuild b/dev-python/SchemaObject/SchemaObject-0.5.3.ebuild
index 5cb07d3f8834..6c56950b7f63 100644
--- a/dev-python/SchemaObject/SchemaObject-0.5.3.ebuild
+++ b/dev-python/SchemaObject/SchemaObject-0.5.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -12,7 +12,9 @@ DESCRIPTION="A simple Python object interface to a MySQL database schema"
HOMEPAGE="http://matuson.com/code/schemaobject/"
SRC_URI="http://www.matuson.com/code/schemaobject/downloads/${P}.tar.gz"
-pn="${PN,,}"
+# Switch to ,, when we switch to EAPI=6.
+#pn="${PN,,}"
+pn="schemaobject"
S="${WORKDIR}/${pn}"
LICENSE="Apache-2.0"
diff --git a/dev-python/cvxopt/cvxopt-1.1.6-r2.ebuild b/dev-python/cvxopt/cvxopt-1.1.6-r2.ebuild
index 256fcd3eb840..150ba1525895 100644
--- a/dev-python/cvxopt/cvxopt-1.1.6-r2.ebuild
+++ b/dev-python/cvxopt/cvxopt-1.1.6-r2.ebuild
@@ -61,9 +61,13 @@ python_prepare_all(){
}
use_cvx() {
- if use $1 ; then
+ local flag=$1
+ if use ${flag} ; then
+ # Switch to ^^ when we switch to EAPI=6.
+ #local uflag=${flag^^}
+ local uflag=$(tr '[:lower:]' '[:upper:]' <<<"${flag}")
sed -i \
- -e "s/\(BUILD_${1^^} =\) 0/\1 1/" \
+ -e "s/\(BUILD_${uflag} =\) 0/\1 1/" \
setup.py || die
fi
}