summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ruby-glib2/ruby-glib2-3.0.7.ebuild')
-rw-r--r--dev-ruby/ruby-glib2/ruby-glib2-3.0.7.ebuild28
1 files changed, 0 insertions, 28 deletions
diff --git a/dev-ruby/ruby-glib2/ruby-glib2-3.0.7.ebuild b/dev-ruby/ruby-glib2/ruby-glib2-3.0.7.ebuild
deleted file mode 100644
index e473e87e3b1d..000000000000
--- a/dev-ruby/ruby-glib2/ruby-glib2-3.0.7.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22 ruby23"
-
-inherit ruby-ng-gnome2
-
-DESCRIPTION="Ruby Glib2 bindings"
-KEYWORDS="amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
-RDEPEND+=" >=dev-libs/glib-2"
-DEPEND+=" >=dev-libs/glib-2"
-
-ruby_add_bdepend "dev-ruby/pkg-config
- test? ( >=dev-ruby/test-unit-2 )"
-
-all_ruby_prepare() {
- # Our sandbox always provides LD_PRELOAD in the environment.
- sed -i -e 's/unless ENV.empty?/unless (ENV.keys - ["LD_PRELOAD"]).empty?/' test/test_spawn.rb || die
-
- # Remove pregenerated Makefile since it will otherwise be shared by all targets.
- rm -f Makefile Makefile.lib ext/glib2/Makefile || die
-}
-
-each_ruby_test() {
- ${RUBY} test/run-test.rb || die
-}