summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/gnomeboyadvance/gnomeboyadvance-0.1.ebuild')
-rw-r--r--games-emulation/gnomeboyadvance/gnomeboyadvance-0.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/games-emulation/gnomeboyadvance/gnomeboyadvance-0.1.ebuild b/games-emulation/gnomeboyadvance/gnomeboyadvance-0.1.ebuild
new file mode 100644
index 000000000000..19e12da60809
--- /dev/null
+++ b/games-emulation/gnomeboyadvance/gnomeboyadvance-0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+PYTHON_DEPEND="2"
+inherit python games
+
+DESCRIPTION="A GNOME Python frontend to VisualBoyAdvance"
+HOMEPAGE="http://developer.berlios.de/projects/gnomeboyadvance/"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="dev-python/libgnome-python
+ dev-python/pygobject:2
+ >=dev-python/pygtk-1.99:2
+ games-emulation/visualboyadvance"
+
+S=${WORKDIR}/gnomeBoyAdvance-0.1
+
+pkg_setup() {
+ python_set_active_version 2
+ games_pkg_setup
+}
+
+src_prepare() {
+ sed -i \
+ -e 's:/usr/share/:/usr/share/games/:' \
+ gnomeboyadvance \
+ || die "sed gnomeboyadvance failed"
+ python_convert_shebangs -r 2 ${PN}
+}
+
+src_install() {
+ dogamesbin gnomeboyadvance || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/gnomeboyadvance
+ doins gnomeBoyAdvance.png gnomeboyadvance.glade || die "doins failed"
+ dodoc README CHANGES TODO
+ prepgamesdirs
+}