summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/kdepim-addons')
-rw-r--r--kde-apps/kdepim-addons/Manifest1
-rw-r--r--kde-apps/kdepim-addons/kdepim-addons-21.04.2.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/kde-apps/kdepim-addons/Manifest b/kde-apps/kdepim-addons/Manifest
index 7ab371f3095a..2bf7f6c86a5d 100644
--- a/kde-apps/kdepim-addons/Manifest
+++ b/kde-apps/kdepim-addons/Manifest
@@ -1,2 +1,3 @@
DIST kdepim-addons-20.12.3.tar.xz 2145600 BLAKE2B 142a519bd57a311042ecbdd1e246a6d4b8bccd64c64d1aeb13755cd5b55383b161082fdd897ccbd2cce83a5f7e9c24b2951cf25f88b2deae90ae0da5737c169d SHA512 345febeb6cd6db60f4c5e246d0a775e828310bca50288e36ba676185404ae5dfe556262a882a201e85cad851b3612a27de15e5b9d6076ee109abdb01e4909058
DIST kdepim-addons-21.04.1.tar.xz 2159104 BLAKE2B 53d61cb1db205482db6ec75ec0fb72d73b01917669ee08329aae97c20dd55d0a6f893c3e6627f559ab7562d168d5e6256ace3041ebe8585c4eb559f78a2661b4 SHA512 c1a016952242c676199ee146a91003f27db235088877794e2f0828ea309bb0cd85cce36d34b802327e16cf27088ff365d4b82242f3c40240559791d171b26234
+DIST kdepim-addons-21.04.2.tar.xz 2270820 BLAKE2B 3b9b9a5ca8c1882f6a7d69da7db29ef9e2084594c25aa50c1058f6875e0d6a812fdcc2567102266340ef1ee366d56a8f6306fb53edf252bea76ad9698d4e964d SHA512 61ac89b12bd1b1b61d3ea617782832a5e6f0e786b118ef475d0425b044c12097638faa8c4e77d659daef41853000a6e0dcd32b4994ef4349ae7d2aff00f073bd
diff --git a/kde-apps/kdepim-addons/kdepim-addons-21.04.2.ebuild b/kde-apps/kdepim-addons/kdepim-addons-21.04.2.ebuild
new file mode 100644
index 000000000000..120baae4dd03
--- /dev/null
+++ b/kde-apps/kdepim-addons/kdepim-addons-21.04.2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.80.0
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org optfeature
+
+DESCRIPTION="Plugins for KDE Personal Information Management Suite"
+HOMEPAGE="https://apps.kde.org/kontact/"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="importwizard markdown"
+
+RDEPEND="
+ >=app-crypt/gpgme-1.11.1[cxx,qt5]
+ >=dev-libs/grantlee-5.2.0:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-contacts-${PVCUT}:5
+ >=kde-apps/akonadi-notes-${PVCUT}:5
+ >=kde-apps/calendarsupport-${PVCUT}:5
+ >=kde-apps/eventviews-${PVCUT}:5
+ >=kde-apps/grantleetheme-${PVCUT}:5
+ >=kde-apps/incidenceeditor-${PVCUT}:5
+ >=kde-apps/kaddressbook-${PVCUT}:5
+ >=kde-apps/kidentitymanagement-${PVCUT}:5
+ >=kde-apps/kimap-${PVCUT}:5
+ >=kde-apps/kitinerary-${PVCUT}:5
+ >=kde-apps/kmailtransport-${PVCUT}:5
+ >=kde-apps/kmime-${PVCUT}:5
+ >=kde-apps/kontactinterface-${PVCUT}:5
+ >=kde-apps/kpkpass-${PVCUT}:5
+ >=kde-apps/libkdepim-${PVCUT}:5
+ >=kde-apps/libkleo-${PVCUT}:5
+ >=kde-apps/libksieve-${PVCUT}:5
+ >=kde-apps/libktnef-${PVCUT}:5
+ >=kde-apps/mailcommon-${PVCUT}:5
+ >=kde-apps/messagelib-${PVCUT}:5
+ >=kde-apps/pimcommon-${PVCUT}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcontacts-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/prison-${KFMIN}:5
+ >=kde-frameworks/syntax-highlighting-${KFMIN}:5
+ importwizard? ( >=kde-apps/akonadi-import-wizard-${PVCUT}:5 )
+ markdown? ( app-text/discount )
+"
+DEPEND="${RDEPEND}"
+
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package importwizard KPimImportWizard)
+ $(cmake_use_find_package markdown Discount)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "regex support for Sieve editor plugin" kde-misc/kregexpeditor
+ fi
+ ecm_pkg_postinst
+}