summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.5.5.ebuild13
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.6.2-r1.ebuild9
2 files changed, 12 insertions, 10 deletions
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.5.5.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.5.5.ebuild
index 155acc7b668d..19156bee619a 100644
--- a/kde-plasma/kwallet-pam/kwallet-pam-5.5.5.ebuild
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.5.5.ebuild
@@ -31,8 +31,8 @@ src_configure() {
pkg_postinst() {
check_dm() {
if [[ -e "${ROOT}${2}" ]] && \
- [[ -n $(egrep "auth\s+optional\s+pam_kwallet5.so" "${ROOT}${2}") ]] && \
- [[ -n $(egrep "session\s+optional\s+pam_kwallet5.so" "${ROOT}${2}") ]]; then
+ grep -Eq "auth\s+optional\s+pam_kwallet5.so" "${ROOT}${2}" && \
+ grep -Eq "session\s+optional\s+pam_kwallet5.so" "${ROOT}${2}" ; then
elog " ${1} - ${2} ...GOOD"
else
ewarn " ${1} - ${2} ...BAD"
@@ -41,12 +41,13 @@ pkg_postinst() {
elog
elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
elog "List of things to make it work:"
- elog "1. Use same password for login and kwallet"
- elog "2. A display manager with support for PAM"
- elog "3.a Have the following lines in the display manager's pam.d file:"
+ elog "1. Use standard blowfish encryption instead of GPG"
+ elog "2. Use same password for login and kwallet"
+ elog "3. A display manager with support for PAM"
+ elog "4.a Have the following lines in the display manager's pam.d file:"
elog " -auth optional pam_kwallet5.so"
elog " -session optional pam_kwallet5.so auto_start"
- elog "3.b Checking installed DMs..."
+ elog "4.b Checking installed DMs..."
has_version "x11-misc/sddm" && check_dm "SDDM" "/etc/pam.d/sddm"
has_version "x11-misc/lightdm" && check_dm "LightDM" "/etc/pam.d/lightdm"
has_version "kde-base/kdm" && check_dm "KDM" "/etc/pam.d/kde"
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.6.2-r1.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.6.2-r1.ebuild
index 9c5669e84166..071301435607 100644
--- a/kde-plasma/kwallet-pam/kwallet-pam-5.6.2-r1.ebuild
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.6.2-r1.ebuild
@@ -73,16 +73,17 @@ pkg_postinst() {
elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
use oldwallet && elog "You have also selected support for legacy kde-apps/kwalletd:4."
elog "List of things to make it work:"
- elog "1. Use same password for login and kwallet"
- elog "2. A display manager with support for PAM"
- elog "3.a Have the following lines in the display manager's pam.d file:"
+ elog "1. Use standard blowfish encryption instead of GPG"
+ elog "2. Use same password for login and kwallet"
+ elog "3. A display manager with support for PAM"
+ elog "4.a Have the following lines in the display manager's pam.d file:"
elog " -auth optional pam_kwallet5.so"
elog " -session optional pam_kwallet5.so auto_start"
if use oldwallet ; then
elog " -auth optional pam_kwallet.so kdehome=.kde4"
elog " -session optional pam_kwallet.so"
fi
- elog "3.b Checking installed DMs..."
+ elog "4.b Checking installed DMs..."
has_version "x11-misc/sddm" && check_dm "SDDM" "/etc/pam.d/sddm"
has_version "x11-misc/lightdm" && check_dm "LightDM" "/etc/pam.d/lightdm"
has_version "kde-base/kdm" && check_dm "KDM" "/etc/pam.d/kde"