summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/pulseaudio-daemon/files')
-rw-r--r--media-sound/pulseaudio-daemon/files/pulseaudio-16.0-optional-module-console-kit.patch76
-rw-r--r--media-sound/pulseaudio-daemon/files/pulseaudio-16.1-module-combine-sink-load-crash.patch26
-rw-r--r--media-sound/pulseaudio-daemon/files/pulseaudio-16.1-module-combine-sink-unload-crash.patch22
-rw-r--r--media-sound/pulseaudio-daemon/files/pulseaudio-16.1-move-qpaeq-to-daemon.patch36
-rw-r--r--media-sound/pulseaudio-daemon/files/pulseaudio-16.99.1-bump-c++17.patch23
5 files changed, 0 insertions, 183 deletions
diff --git a/media-sound/pulseaudio-daemon/files/pulseaudio-16.0-optional-module-console-kit.patch b/media-sound/pulseaudio-daemon/files/pulseaudio-16.0-optional-module-console-kit.patch
deleted file mode 100644
index 4ffdb82f4901..000000000000
--- a/media-sound/pulseaudio-daemon/files/pulseaudio-16.0-optional-module-console-kit.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-commit 823e46fba0742605f557b68cd591f61624b93966
-Author: Igor V. Kovalenko <igor.v.kovalenko@gmail.com>
-Date: Sun Jun 12 21:49:32 2022 +0300
-
- build-sys: meson: Make module-console-kit optional
-
- Default build configuration would fail to run on a system without systemd-logind
- (or elogind) and without ConsoleKit daemon responding on dbus interface. Here,
- module-console-kit would fail to initialize, preventing daemon from starting.
-
- Make module-console-kit an optional build feature to allow opt-out.
-
- Part-of: <https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/719>
-
-diff --git a/meson.build b/meson.build
-index d4cdbd6a5..c6db7e670 100644
---- a/meson.build
-+++ b/meson.build
-@@ -732,6 +732,10 @@ if get_option('daemon')
- cdata.set('HAVE_SYSTEMD_LOGIN', 1)
- endif
-
-+ if get_option('consolekit').enabled()
-+ assert(dbus_dep.found(), 'ConsoleKit requires D-Bus support')
-+ endif
-+
- tcpwrap_dep = cc.find_library('wrap', required: get_option('tcpwrap'))
- if cc.has_header('tcpd.h') and cc.has_function('hosts_access', dependencies : tcpwrap_dep)
- cdata.set('HAVE_LIBWRAP', 1)
-@@ -1001,6 +1005,7 @@ summary += [
- ' Enable HAL->udev compat: @0@'.format(get_option('hal-compat')),
- 'Enable systemd units: @0@'.format(systemd_dep.found()),
- 'Enable elogind: @0@'.format(libelogind_dep.found()),
-+ 'Enable ConsoleKit: @0@'.format(not get_option('consolekit').disabled() and dbus_dep.found()),
- 'Enable TCP Wrappers: @0@'.format(tcpwrap_dep.found()),
- 'Enable OpenSSL (for Airtunes): @0@'.format(openssl_dep.found()),
- 'Database: @0@'.format(get_option('database')),
-diff --git a/meson_options.txt b/meson_options.txt
-index b23210072..e7160a3a7 100644
---- a/meson_options.txt
-+++ b/meson_options.txt
-@@ -99,6 +99,9 @@ option('bluez5-native-headset',
- option('bluez5-ofono-headset',
- type : 'boolean',
- description : 'Optional oFono headset backend support (BlueZ 5)')
-+option('consolekit',
-+ type : 'feature', value : 'auto',
-+ description : 'Optional ConsoleKit support')
- option('dbus',
- type : 'feature', value : 'auto',
- description : 'Optional D-Bus support')
-diff --git a/src/modules/meson.build b/src/modules/meson.build
-index cdf372c8e..1d8004300 100644
---- a/src/modules/meson.build
-+++ b/src/modules/meson.build
-@@ -130,7 +130,6 @@ endif
-
- if dbus_dep.found()
- all_modules += [
-- [ 'module-console-kit', 'module-console-kit.c', [], [], [dbus_dep] ],
- [ 'module-dbus-protocol',
- [ 'dbus/iface-card.c', 'dbus/iface-card.h',
- 'dbus/iface-card-profile.c', 'dbus/iface-card-profile.h',
-@@ -147,6 +146,12 @@ if dbus_dep.found()
- [], [], [dbus_dep] ],
- [ 'module-rygel-media-server', 'module-rygel-media-server.c', [], [], [dbus_dep], libprotocol_http ],
- ]
-+
-+ if not get_option('consolekit').disabled()
-+ all_modules += [
-+ [ 'module-console-kit', 'module-console-kit.c', [], [], [dbus_dep] ],
-+ ]
-+ endif
- endif
-
- if fftw_dep.found()
diff --git a/media-sound/pulseaudio-daemon/files/pulseaudio-16.1-module-combine-sink-load-crash.patch b/media-sound/pulseaudio-daemon/files/pulseaudio-16.1-module-combine-sink-load-crash.patch
deleted file mode 100644
index d02c1029f8b0..000000000000
--- a/media-sound/pulseaudio-daemon/files/pulseaudio-16.1-module-combine-sink-load-crash.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-commit 37c72c20720d6f7fefeeb151f5e10c2cd0dda30e
-Author: Igor V. Kovalenko <igor.v.kovalenko@gmail.com>
-Date: Sun Nov 27 22:30:45 2022 +0300
-
- module-combine-sink: Do not set up rate adjustment timer at load time
-
- Rate adjustment timer is set up when combine sink is resumed and relased when
- combine sink is suspended. Do not create this timer again while module is loaded
- to prevent duplicate effort causing assertion in time_callback.
-
- Part-of: <https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/756>
-
-diff --git a/src/modules/module-combine-sink.c b/src/modules/module-combine-sink.c
-index f98f4820b..4b7690183 100644
---- a/src/modules/module-combine-sink.c
-+++ b/src/modules/module-combine-sink.c
-@@ -1711,9 +1711,6 @@ int pa__init(pa_module*m) {
- PA_IDXSET_FOREACH(o, u->outputs, idx)
- output_verify(o);
-
-- if (u->adjust_time > 0)
-- u->time_event = pa_core_rttime_new(m->core, pa_rtclock_now() + u->adjust_time, time_callback, u);
--
- pa_modargs_free(ma);
-
- return 0;
diff --git a/media-sound/pulseaudio-daemon/files/pulseaudio-16.1-module-combine-sink-unload-crash.patch b/media-sound/pulseaudio-daemon/files/pulseaudio-16.1-module-combine-sink-unload-crash.patch
deleted file mode 100644
index f0cd82dde16e..000000000000
--- a/media-sound/pulseaudio-daemon/files/pulseaudio-16.1-module-combine-sink-unload-crash.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-commit 0cbbc408aee2b5f2c42280d24dc615405387b5b1
-Author: Igor V. Kovalenko <igor.v.kovalenko@gmail.com>
-Date: Sun Nov 27 19:39:23 2022 +0300
-
- module-combine-sink: Suspend while unloading to fix crash moving sinks
-
- Part-of: <https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/756>
-
-diff --git a/src/modules/module-combine-sink.c b/src/modules/module-combine-sink.c
-index 4b7690183..2ccd9eb13 100644
---- a/src/modules/module-combine-sink.c
-+++ b/src/modules/module-combine-sink.c
-@@ -1733,6 +1733,9 @@ void pa__done(pa_module*m) {
- if (!(u = m->userdata))
- return;
-
-+ if (u->sink && PA_SINK_IS_LINKED(u->sink->state))
-+ pa_sink_suspend(u->sink, true, PA_SUSPEND_UNAVAILABLE);
-+
- pa_strlist_free(u->unlinked_slaves);
-
- if (u->sink_put_slot)
diff --git a/media-sound/pulseaudio-daemon/files/pulseaudio-16.1-move-qpaeq-to-daemon.patch b/media-sound/pulseaudio-daemon/files/pulseaudio-16.1-move-qpaeq-to-daemon.patch
deleted file mode 100644
index d3943bf10a49..000000000000
--- a/media-sound/pulseaudio-daemon/files/pulseaudio-16.1-move-qpaeq-to-daemon.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-commit 07a9fcefbab049d66cb174ca2c9b91fecc444c5b
-Author: Igor V. Kovalenko <igor.v.kovalenko@gmail.com>
-Date: Sat Jul 9 09:12:38 2022 +0300
-
- build-sys: meson: Move qpaeq to daemon build
-
- Equalizer control requires server modules only available when daemon is built.
- Move qpaeq script to be installed together with daemon.
-
- Part-of: <https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/734>
-
-diff --git a/src/utils/meson.build b/src/utils/meson.build
-index 28e1fc10a..8496d0bc5 100644
---- a/src/utils/meson.build
-+++ b/src/utils/meson.build
-@@ -72,6 +72,10 @@ if get_option('daemon')
- c_args : pa_c_args,
- )
- endif
-+
-+ if dbus_dep.found() and fftw_dep.found()
-+ install_data('qpaeq', install_dir : bindir)
-+ endif
- endif
-
- if get_option('client')
-@@ -117,9 +121,5 @@ if get_option('client')
- )
- endif
-
-- if dbus_dep.found() and fftw_dep.found()
-- install_data('qpaeq', install_dir : bindir)
-- endif
--
- install_data('pa-info', install_dir : bindir)
- endif
diff --git a/media-sound/pulseaudio-daemon/files/pulseaudio-16.99.1-bump-c++17.patch b/media-sound/pulseaudio-daemon/files/pulseaudio-16.99.1-bump-c++17.patch
deleted file mode 100644
index c7aa9d8aadbe..000000000000
--- a/media-sound/pulseaudio-daemon/files/pulseaudio-16.99.1-bump-c++17.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-commit e2b63d157fcc5ceb67a2f0eaed202d18baa05a11
-Author: Arun Raghavan <arun@asymptotic.io>
-Date: Sun Aug 13 07:24:41 2023 -0400
-
- build-sys: Bump cpp_std to c++17
-
- Match it with webrtc-audio-processing, which is what we care about.
-
- Part-of: <https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/795>
-
-diff --git a/meson.build b/meson.build
-index daa80b573..ba3d01dac 100644
---- a/meson.build
-+++ b/meson.build
-@@ -1,7 +1,7 @@
- project('pulseaudio', 'c',
- version : run_command(find_program('git-version-gen'), join_paths(meson.current_source_dir(), '.tarball-version'), check : false).stdout().strip(),
- meson_version : '>= 0.50.0',
-- default_options : [ 'c_std=gnu11', 'cpp_std=c++11' ]
-+ default_options : [ 'c_std=gnu11', 'cpp_std=c++17' ]
- )
-
- if not meson.is_subproject()