summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/pgmfindclip/pgmfindclip-1.13.ebuild')
-rw-r--r--media-video/pgmfindclip/pgmfindclip-1.13.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-video/pgmfindclip/pgmfindclip-1.13.ebuild b/media-video/pgmfindclip/pgmfindclip-1.13.ebuild
new file mode 100644
index 000000000000..84f03032f1e9
--- /dev/null
+++ b/media-video/pgmfindclip/pgmfindclip-1.13.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+IUSE=""
+
+S="${WORKDIR}"
+
+DESCRIPTION="automatically find a clipping border for a sequence of pgm images"
+HOMEPAGE="http://www.lallafa.de/bp/pgmfindclip.html"
+SRC_URI="http://www.lallafa.de/bp/files/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i -e 's:gcc .* -o:$(CC) $(CFLAGS) $(LDFLAGS) -o:' "${S}"/Makefile
+}
+
+src_compile () {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install () {
+ dobin ${PN} || die
+}