summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/nfs-utils/nfs-utils-2.4.1.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/net-fs/nfs-utils/nfs-utils-2.4.1.ebuild b/net-fs/nfs-utils/nfs-utils-2.4.1.ebuild
index c579954763ad..aff15752fd00 100644
--- a/net-fs/nfs-utils/nfs-utils-2.4.1.ebuild
+++ b/net-fs/nfs-utils/nfs-utils-2.4.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools flag-o-matic multilib systemd
+inherit autotools flag-o-matic linux-info multilib systemd
DESCRIPTION="NFS client and server daemons"
HOMEPAGE="http://linux-nfs.org/"
@@ -70,6 +70,16 @@ PATCHES=(
"${FILESDIR}"/${P}-gssd-Look-in-lib32-for-gss-libs-aswell.patch
)
+pkg_setup() {
+ linux-info_pkg_setup
+ if use nfsv4 && ! use nfsdcld && linux_config_exists && ! linux_chkconfig_present CRYPTO_MD5 ; then
+ ewarn "Your NFS server will be unable to track clients across server restarts!"
+ ewarn "Please enable the \"${HILITE}nfsdcld${NORMAL}\" USE flag to install the nfsdcltrack usermode"
+ ewarn "helper upcall program, or enable ${HILITE}CONFIG_CRYPTO_MD5${NORMAL} in your kernel to"
+ ewarn "support the legacy, in-kernel client tracker."
+ fi
+}
+
src_prepare() {
default