summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/filezilla')
-rw-r--r--net-ftp/filezilla/filezilla-3.13.0.ebuild14
1 files changed, 14 insertions, 0 deletions
diff --git a/net-ftp/filezilla/filezilla-3.13.0.ebuild b/net-ftp/filezilla/filezilla-3.13.0.ebuild
index 51f25926c61b..3f0e7a090ea6 100644
--- a/net-ftp/filezilla/filezilla-3.13.0.ebuild
+++ b/net-ftp/filezilla/filezilla-3.13.0.ebuild
@@ -36,6 +36,20 @@ DEPEND="${RDEPEND}
S="${WORKDIR}"/${PN}-${MY_PV}
+pkg_pretend() {
+if [[ ${MERGE_TYPE} != binary ]]; then
+ echo 'int main() {return 0;}' > "${T}"/test.cxx || die
+ ebegin "Trying to build a C++14 test program"
+ if ! $(tc-getCXX) -std=c++14 -o /dev/null "${T}"/test.cxx; then
+ eerror "${P} requires C++14-capable C++ compiler. Your current compiler"
+ eerror "does not seem to support -std=c++14 option. Please upgrade your compiler"
+ eerror "to gcc-4.9 or an equivalent version supporting C++14."
+ die "Currently active compiler does not support -std=c++14"
+ fi
+ eend ${?}
+ fi
+}
+
src_prepare() {
# Missing in tarball
cp -a "${FILESDIR}"/${P}-fzputtygen_interface.h \