summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/profxp')
-rw-r--r--net-ftp/profxp/Manifest2
-rw-r--r--net-ftp/profxp/metadata.xml7
-rw-r--r--net-ftp/profxp/profxp-3_pre2-r2.ebuild46
3 files changed, 55 insertions, 0 deletions
diff --git a/net-ftp/profxp/Manifest b/net-ftp/profxp/Manifest
new file mode 100644
index 000000000000..b063777f0a8e
--- /dev/null
+++ b/net-ftp/profxp/Manifest
@@ -0,0 +1,2 @@
+DIST SOCKS.pm 17069 SHA256 dffb26ecafc4fdd052d398a51e4edf4dd97082a7d6b56781b352bc3458a48cc1 SHA512 87029d9fb58ba384499a2ac73d661dd4c91faa81636e41c1d3c3a1d1efab1d5e01804467428d1daf8dd2fcb231666e2986f6cc806f5f7d419e7d3280a95c497e WHIRLPOOL ce63a9effc6beaea7a5d2dc462511db1c7677266eaeb6255d2e652bedb320b20e0bb9d1b0966f7f59f91dc9fcff80cff854441f1f0ddb3f603f89523bba82cc9
+DIST profxp-v3-pre2-src.tar.gz 16647 SHA256 975af5393b2a66bdca378b349d5c674551b668858e0ac505763052170e484452 SHA512 5f48e15f0c6c43c8b20b7cb72bf642e12a99d469bea21372a7a602d5f8522c4097d18918a3a007961b3ea6177ec864d50a7bc24211194ac9d791c5190978e167 WHIRLPOOL b69c6a7284d0b73288b611fd586d8a7622c6d945a50321caa73e135ec9b1e8c7b9156564cb15f1c1f2ba51ecc2489fd2ef937a23a7f53173ac69db7a236f1271
diff --git a/net-ftp/profxp/metadata.xml b/net-ftp/profxp/metadata.xml
new file mode 100644
index 000000000000..d9cd2cad66c2
--- /dev/null
+++ b/net-ftp/profxp/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/net-ftp/profxp/profxp-3_pre2-r2.ebuild b/net-ftp/profxp/profxp-3_pre2-r2.ebuild
new file mode 100644
index 000000000000..7299f2f1d63e
--- /dev/null
+++ b/net-ftp/profxp/profxp-3_pre2-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="FXP (server-to-server FTP) commandline client written in Perl"
+HOMEPAGE="http://duncanthrax.net/profxp/"
+SRC_URI="http://duncanthrax.net/profxp/profxp-v${PV/_/-}-src.tar.gz
+ http://search.cpan.org/src/CLINTDW/SOCKS-0.03/lib/Net/SOCKS.pm"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="virtual/perl-Time-HiRes
+ dev-perl/TermReadKey
+ dev-perl/Term-ReadLine-Perl"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack profxp-v${PV/_/-}-src.tar.gz
+ cp "${DISTDIR}"/SOCKS.pm "${S}"/
+}
+
+src_prepare() {
+ sed -i 's:/home/tom/ActivePerl-5\.6:/usr:' "${S}"/profxpv3.pl || die
+}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ perl_set_version
+ newbin profxpv3.pl profxp.pl
+ dosym profxp.pl /usr/bin/profxp
+ insinto ${ARCH_LIB}/Net
+ doins SOCKS.pm
+ insinto ${ARCH_LIB}/${PN}
+ doins ${PN}/*.pm
+}