summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/onionrouter/files/onionrouter-0.5.2-pyyaml-version.patch')
-rw-r--r--net-mail/onionrouter/files/onionrouter-0.5.2-pyyaml-version.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-mail/onionrouter/files/onionrouter-0.5.2-pyyaml-version.patch b/net-mail/onionrouter/files/onionrouter-0.5.2-pyyaml-version.patch
new file mode 100644
index 000000000000..f8c7304a977f
--- /dev/null
+++ b/net-mail/onionrouter/files/onionrouter-0.5.2-pyyaml-version.patch
@@ -0,0 +1,25 @@
+https://github.com/ehloonion/onionrouter/pull/17
+
+From cdac2f500b24abaf5833266ad740c56df360e602 Mon Sep 17 00:00:00 2001
+From: Craig Andrews <candrews@integralblue.com>
+Date: Mon, 19 Oct 2020 12:56:19 -0400
+Subject: [PATCH] Allow for use of later versions of PyYAML
+
+commit 5fe349a "Update PyYAML to 4.2b1 due to CVE-2017-18342" set `install_requires` to `PyYAML==4.2b1`. This exact version requirement prohibits the use of later versions of PyYAML.
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index baf6041..85e0b81 100644
+--- a/setup.py
++++ b/setup.py
+@@ -11,7 +11,7 @@
+
+ requirements = [
+ "dnspython",
+- "PyYAML==4.2b1",
++ "PyYAML>=4.2b1",
+ ]
+
+ test_requirements = [