summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/socket/socket-1.5.ebuild')
-rw-r--r--net-misc/socket/socket-1.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/socket/socket-1.5.ebuild b/net-misc/socket/socket-1.5.ebuild
new file mode 100644
index 000000000000..46528c1242f1
--- /dev/null
+++ b/net-misc/socket/socket-1.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit base toolchain-funcs
+
+DESCRIPTION="A shell-level interface to TCP sockets"
+HOMEPAGE="http://www.jnickelsen.de/socket/"
+SRC_URI="http://www.jnickelsen.de/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+
+IUSE="examples"
+
+PATCHES=( "${FILESDIR}/${P}-makefile.patch" )
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin socket
+ doman socket.1
+ dodoc BLURB CHANGES README
+ if use examples; then
+ docinto examples
+ dodoc scripts/*
+ fi
+}