summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/qbittorrent/qbittorrent-3.3.16.ebuild')
-rw-r--r--net-p2p/qbittorrent/qbittorrent-3.3.16.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/qbittorrent-3.3.16.ebuild b/net-p2p/qbittorrent/qbittorrent-3.3.16.ebuild
index ddac9c49ab69..6511503962b7 100644
--- a/net-p2p/qbittorrent/qbittorrent-3.3.16.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-3.3.16.ebuild
@@ -45,6 +45,13 @@ DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # bug 641010
+ sed -i -e "s/-Werror //" cmake/Modules/MacroQbtCompilerSettings.cmake || die
+}
+
src_configure() {
local mycmakeargs=(
-DSYSTEM_QTSINGLEAPPLICATION=ON