summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/p3d/p3d-9999.ebuild')
-rw-r--r--sci-chemistry/p3d/p3d-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-chemistry/p3d/p3d-9999.ebuild b/sci-chemistry/p3d/p3d-9999.ebuild
new file mode 100644
index 000000000000..e0f8087a0cc2
--- /dev/null
+++ b/sci-chemistry/p3d/p3d-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit git-2 distutils versionator
+
+DESCRIPTION="Python module for structural bioinformatics"
+HOMEPAGE="http://p3d.fufezan.net/"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/fu/p3d.git"
+
+SLOT="0"
+KEYWORDS=""
+LICENSE="GPL-3"
+IUSE="examples"
+
+S="${WORKDIR}"/${PN}
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r pdbs exampleScripts || die
+ fi
+}