summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/osm2pgsql/osm2pgsql-99999999.ebuild')
-rw-r--r--sci-geosciences/osm2pgsql/osm2pgsql-99999999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-geosciences/osm2pgsql/osm2pgsql-99999999.ebuild b/sci-geosciences/osm2pgsql/osm2pgsql-99999999.ebuild
new file mode 100644
index 000000000000..3a7fcf724fe8
--- /dev/null
+++ b/sci-geosciences/osm2pgsql/osm2pgsql-99999999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools git-2
+
+EGIT_REPO_URI="git://github.com/openstreetmap/osm2pgsql.git"
+EGIT_BOOTSTRAP="eautoreconf"
+
+DESCRIPTION="Converts OSM planet.osm data to a PostgreSQL/PostGIS database"
+HOMEPAGE="http://wiki.openstreetmap.org/wiki/Osm2pgsql"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="+lua +pbf"
+
+DEPEND="
+ app-arch/bzip2
+ dev-db/postgresql:=
+ dev-libs/boost
+ dev-libs/libxml2:2
+ sci-libs/geos
+ sci-libs/proj
+ sys-libs/zlib
+ lua? ( dev-lang/lua:= )
+ pbf? ( dev-libs/protobuf-c )
+"
+RDEPEND="${DEPEND}"