summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/arpack/arpack-9999.ebuild')
-rw-r--r--sci-libs/arpack/arpack-9999.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/sci-libs/arpack/arpack-9999.ebuild b/sci-libs/arpack/arpack-9999.ebuild
index 543b592a542d..312d55c7b9be 100644
--- a/sci-libs/arpack/arpack-9999.ebuild
+++ b/sci-libs/arpack/arpack-9999.ebuild
@@ -1,21 +1,22 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools fortran-2 toolchain-funcs
+DESCRIPTION="Arnoldi package library to solve large scale eigenvalue problems"
+HOMEPAGE="http://www.caam.rice.edu/software/ARPACK/ https://github.com/opencollab/arpack-ng"
+
if [[ ${PV} == *9999 ]]; then
- inherit git-r3
EGIT_REPO_URI="https://github.com/opencollab/arpack-ng"
+ inherit git-r3
else
SRC_URI="https://github.com/opencollab/${PN}-ng/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
S="${WORKDIR}/${PN}-ng-${PV}"
fi
-DESCRIPTION="Arnoldi package library to solve large scale eigenvalue problems"
-HOMEPAGE="http://www.caam.rice.edu/software/ARPACK/ https://github.com/opencollab/arpack-ng"
LICENSE="BSD"
SLOT="0"
IUSE="examples mpi"
@@ -23,7 +24,8 @@ IUSE="examples mpi"
RDEPEND="
virtual/blas
virtual/lapack
- mpi? ( virtual/mpi[fortran] )"
+ mpi? ( virtual/mpi[fortran] )
+"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"