summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/why3')
-rw-r--r--sci-mathematics/why3/files/why3-1.7.2-signum.patch11
-rw-r--r--sci-mathematics/why3/why3-1.7.2.ebuild2
2 files changed, 13 insertions, 0 deletions
diff --git a/sci-mathematics/why3/files/why3-1.7.2-signum.patch b/sci-mathematics/why3/files/why3-1.7.2-signum.patch
new file mode 100644
index 000000000000..97c014df8b91
--- /dev/null
+++ b/sci-mathematics/why3/files/why3-1.7.2-signum.patch
@@ -0,0 +1,11 @@
+--- a/src/server/cpulimit-unix.c 2024-11-20 22:37:00.519645455 +0100
++++ b/src/server/cpulimit-unix.c 2024-11-20 22:39:55.096447774 +0100
+@@ -42,7 +42,7 @@
+ }
+ }
+
+-void wallclock_timelimit_reached() {
++void wallclock_timelimit_reached(__attribute__((unused)) int signum) {
+ fprintf(stderr,
+ "Why3cpulimit: wallclock timelimit %d reached, killing command\n",
+ wallclock_timelimit);
diff --git a/sci-mathematics/why3/why3-1.7.2.ebuild b/sci-mathematics/why3/why3-1.7.2.ebuild
index 7517d54b1b67..888c5c48f865 100644
--- a/sci-mathematics/why3/why3-1.7.2.ebuild
+++ b/sci-mathematics/why3/why3-1.7.2.ebuild
@@ -46,6 +46,8 @@ BDEPEND="
DOCS=( CHANGES.md README.md )
+PATCHES=( "${FILESDIR}"/${P}-signum.patch )
+
src_prepare() {
mv configure.in configure.ac || die