summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/radeon-profile-daemon/radeon-profile-daemon-99999999.ebuild')
-rw-r--r--x11-apps/radeon-profile-daemon/radeon-profile-daemon-99999999.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/x11-apps/radeon-profile-daemon/radeon-profile-daemon-99999999.ebuild b/x11-apps/radeon-profile-daemon/radeon-profile-daemon-99999999.ebuild
index ca74330cfd3c..924760fc9099 100644
--- a/x11-apps/radeon-profile-daemon/radeon-profile-daemon-99999999.ebuild
+++ b/x11-apps/radeon-profile-daemon/radeon-profile-daemon-99999999.ebuild
@@ -27,8 +27,14 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}/${P}/${PN}"
+PATCHES=(
+ "${FILESDIR}/${P}-secure_socket.patch"
+)
+
src_prepare() {
- default
+ eapply -p2 "${PATCHES[@]}"
+ eapply_user
+
sed \
-e '/^bin\.path/s@/bin@/sbin@' \
-e "/^service\.path/s@=.*\$@= $(systemd_get_systemunitdir)@" \
@@ -47,3 +53,8 @@ src_install() {
newinitd "${FILESDIR}"/${PN}.initd ${PN}
}
+
+pkg_postinst() {
+ elog "Users need to be in the \"video\" group if they want to change"
+ elog "video card settings via ${PN}"
+}