summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/stalonetray/stalonetray-0.8.3.ebuild')
-rw-r--r--x11-misc/stalonetray/stalonetray-0.8.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-misc/stalonetray/stalonetray-0.8.3.ebuild b/x11-misc/stalonetray/stalonetray-0.8.3.ebuild
new file mode 100644
index 000000000000..615494594418
--- /dev/null
+++ b/x11-misc/stalonetray/stalonetray-0.8.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="System tray utility including support for KDE system tray icons"
+HOMEPAGE="http://stalonetray.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +graceful-exit kde"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_configure() {
+ econf $(use_enable debug) \
+ $(use_enable graceful-exit) \
+ $(use_enable kde native-kde)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog NEWS README stalonetrayrc.sample TODO
+ dohtml stalonetray.html
+}