summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xpad/xpad-5.7.0.ebuild')
-rw-r--r--x11-misc/xpad/xpad-5.7.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-misc/xpad/xpad-5.7.0.ebuild b/x11-misc/xpad/xpad-5.7.0.ebuild
new file mode 100644
index 000000000000..86f88b038215
--- /dev/null
+++ b/x11-misc/xpad/xpad-5.7.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools
+
+DESCRIPTION="A sticky note application for GTK"
+HOMEPAGE="https://launchpad.net/xpad"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk
+ dev-libs/atk
+ >=dev-libs/glib-2.58:2
+ sys-devel/gettext
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3[X]
+ x11-libs/gtksourceview:4
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/pango
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-util/intltool-0.31
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}