summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/fluxter/fluxter-0.1.0.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/x11-misc/fluxter/fluxter-0.1.0.ebuild b/x11-misc/fluxter/fluxter-0.1.0.ebuild
index 0bcbe35e507e..121d5f5ed917 100644
--- a/x11-misc/fluxter/fluxter-0.1.0.ebuild
+++ b/x11-misc/fluxter/fluxter-0.1.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
-inherit autotools eutils
+EAPI=6
+inherit autotools
DESCRIPTION="workspace pager dockapp, particularly useful with the Fluxbox window manager"
HOMEPAGE="http://www.isomedia.com/homes/stevencooper"
@@ -17,8 +17,10 @@ DEPEND="x11-libs/libX11
x11-libs/libSM
x11-libs/libICE"
+PATCHES=( "${FILESDIR}/${P}-asneeded.patch" )
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-asneeded.patch
+ default
eautoreconf
}
@@ -29,5 +31,4 @@ src_configure() {
src_install() {
emake DESTDIR="${D}" install || die
- dodoc AUTHORS BUGS ChangeLog README TODO
}