summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmmand')
-rw-r--r--x11-plugins/wmmand/Manifest1
-rw-r--r--x11-plugins/wmmand/metadata.xml8
-rw-r--r--x11-plugins/wmmand/wmmand-1.3.2.ebuild38
3 files changed, 47 insertions, 0 deletions
diff --git a/x11-plugins/wmmand/Manifest b/x11-plugins/wmmand/Manifest
new file mode 100644
index 000000000000..1bfa5c468b02
--- /dev/null
+++ b/x11-plugins/wmmand/Manifest
@@ -0,0 +1 @@
+DIST wmMand-1.3.2.tar.bz2 41268 SHA256 c12127e8bc0b0d70c3fbaabaf1d6e2322c673a9e001ab4448804e7a0d39bcfea
diff --git a/x11-plugins/wmmand/metadata.xml b/x11-plugins/wmmand/metadata.xml
new file mode 100644
index 000000000000..e5448f757656
--- /dev/null
+++ b/x11-plugins/wmmand/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-dock</herd>
+ <upstream>
+ <remote-id type="sourceforge">wmmand</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-plugins/wmmand/wmmand-1.3.2.ebuild b/x11-plugins/wmmand/wmmand-1.3.2.ebuild
new file mode 100644
index 000000000000..08cb5a161cd4
--- /dev/null
+++ b/x11-plugins/wmmand/wmmand-1.3.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+MY_P=wmMand-${PV}
+
+DESCRIPTION="a dockable mandelbrot browser"
+HOMEPAGE="http://ciotog.homelinux.net/software/wmMand/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+S=${WORKDIR}/${MY_P}/wmMand
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" \
+ SYSTEM="${LDFLAGS}" \
+ INCDIR="" LIBDIR="" || die "emake failed."
+}
+
+src_install() {
+ dobin wmMand || die "dobin failed."
+ doman wmMand.6.gz
+ doicon wmMand.png
+ dodoc ../{BUGS,changelog,TODO}
+}