summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/gargantuan-icon-theme/gargantuan-icon-theme-1.7.ebuild')
-rw-r--r--x11-themes/gargantuan-icon-theme/gargantuan-icon-theme-1.7.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-themes/gargantuan-icon-theme/gargantuan-icon-theme-1.7.ebuild b/x11-themes/gargantuan-icon-theme/gargantuan-icon-theme-1.7.ebuild
new file mode 100644
index 000000000000..125a5bd48294
--- /dev/null
+++ b/x11-themes/gargantuan-icon-theme/gargantuan-icon-theme-1.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit gnome2-utils
+
+DESCRIPTION="Gargantuan Icon Theme"
+HOMEPAGE="http://www.gnome-look.org/content/show.php?content=24364"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="x11-themes/hicolor-icon-theme"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/gargantuan
+
+src_install() {
+ dodoc README || die
+ rm -f index.theme~ index.theme.old icons/iconrc~ README || die
+ insinto /usr/share/icons/gargantuan
+ doins -r * || die
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }