summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/stumpwm')
-rw-r--r--x11-wm/stumpwm/stumpwm-0.9.9.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/x11-wm/stumpwm/stumpwm-0.9.9.ebuild b/x11-wm/stumpwm/stumpwm-0.9.9.ebuild
index 29808a6e8aa5..00a90c7d1db8 100644
--- a/x11-wm/stumpwm/stumpwm-0.9.9.ebuild
+++ b/x11-wm/stumpwm/stumpwm-0.9.9.ebuild
@@ -72,7 +72,10 @@ src_prepare() {
}
src_configure() {
- econf --with-lisp=$(get_lisp sbcl clisp ecl) --with-module-dir="${CLSOURCEROOT}/${CLPACKAGE}/contrib"
+ local moduleconfig
+
+ use contrib && moduleconfig="--with-module-dir=${CLSOURCEROOT}/${CLPACKAGE}/contrib"
+ econf --with-lisp=$(get_lisp sbcl clisp ecl) "${moduleconfig}"
}
src_compile() {