summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-netload-plugin/xfce4-netload-plugin-1.2.0-r1.ebuild')
-rw-r--r--xfce-extra/xfce4-netload-plugin/xfce4-netload-plugin-1.2.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-netload-plugin/xfce4-netload-plugin-1.2.0-r1.ebuild b/xfce-extra/xfce4-netload-plugin/xfce4-netload-plugin-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..58815944dc6f
--- /dev/null
+++ b/xfce-extra/xfce4-netload-plugin/xfce4-netload-plugin-1.2.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit multilib xfconf
+
+DESCRIPTION="A network load plug-in for the Xfce panel"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-netload-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND=">=xfce-base/libxfce4ui-4.10
+ >=xfce-base/xfce4-panel-4.10"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/${P}-interface_name_length.patch )
+
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}