summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn M. Harris Jr. <johnmh@johnmh.me>2024-07-26 19:41:44 -0700
committerJohn M. Harris Jr. <johnmh@johnmh.me>2024-07-26 19:58:51 -0700
commitf08d05bfd213b9d260810b318c499a73ffa8074c (patch)
tree3216191a6f3a8ba8d09f2d6163df0f77e9e48919
parentdev-libs/hyprlang: treeclean (diff)
downloadjohnmh-f08d05bfd213b9d260810b318c499a73ffa8074c.tar.gz
johnmh-f08d05bfd213b9d260810b318c499a73ffa8074c.tar.bz2
johnmh-f08d05bfd213b9d260810b318c499a73ffa8074c.zip
media-sound/strawberry: new package, add 9999
Signed-off-by: John M. Harris Jr. <johnmh@johnmh.me>
-rw-r--r--media-sound/strawberry/Manifest2
-rw-r--r--media-sound/strawberry/metadata.xml20
-rw-r--r--media-sound/strawberry/strawberry-9999.ebuild112
3 files changed, 134 insertions, 0 deletions
diff --git a/media-sound/strawberry/Manifest b/media-sound/strawberry/Manifest
new file mode 100644
index 0000000..349afa8
--- /dev/null
+++ b/media-sound/strawberry/Manifest
@@ -0,0 +1,2 @@
+EBUILD strawberry-9999.ebuild 2963 BLAKE2B 1ce98f03f17503a9b1edcc421b9baef8f8390d584598c60a0accb142a3fe4cd69fdfb7b8c8a5cc91458bcc200c1321f3ee018ccf64dc8a18debc6ce591b0f8cb SHA512 b3cf25c4117599d30cbe6143c3ab3271027ffb3c7b546a1f5037f422e216672beed2d219b9087f27eb50063fab4a4fe5f84511470a3a4dc2e72dbf4e2b8f8e58
+MISC metadata.xml 632 BLAKE2B 959bfab4e15d7be1a27ee281ce6f2d34eec021d408eb5d6da5463ce878deeec253f434bcad4246ced9b8ae7d1a7bc977bd4ba67bdd251fcfc775c4c57b8a2998 SHA512 dc26a7b05e6bbe0693c8f48eb54ec835f148e37a8b7ded2e04ca3d209c87c455e3d54cb507a67d4f8c99c30a26141c5be0dffe8feef7bca2e5be5e017173b6c8
diff --git a/media-sound/strawberry/metadata.xml b/media-sound/strawberry/metadata.xml
new file mode 100644
index 0000000..aac4c14
--- /dev/null
+++ b/media-sound/strawberry/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>johnmh@johnmh.me</email>
+ <name>John M. Harris, Jr.</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sound@gentoo.org</email>
+ <name>Gentoo Sound project</name>
+ </maintainer>
+ <use>
+ <flag name="vlc">Enable <pkg>media-video/vlc</pkg> backend</flag>
+ <flag name="moodbar">Enable moodbar support</flag>
+ <flag name="soup">Enable soup support</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">jonaski/strawberry</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/strawberry/strawberry-9999.ebuild b/media-sound/strawberry/strawberry-9999.ebuild
new file mode 100644
index 0000000..8aa029c
--- /dev/null
+++ b/media-sound/strawberry/strawberry-9999.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic plocale xdg
+
+PLOCALES="ca_ES cs_CZ de_DE es_AR es_ES es_MX et_EE fi_FI fr_FR hu_HU id_ID it_IT ja_JP ko_KR nb_NO nl_NL pl_PL pt_BR ru_RU sv_SE uk_UA zh_CN zh_TW"
+
+DESCRIPTION="Modern music player and library organizer based on Clementine and Qt"
+HOMEPAGE="https://www.strawberrymusicplayer.org/"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/strawberrymusicplayer/strawberry"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/strawberrymusicplayer/strawberry/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="cdda debug +gstreamer ipod moodbar mtp pulseaudio +udisks vlc"
+
+BDEPEND="
+ dev-qt/qttools:6[linguist]
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+COMMON_DEPEND="
+ dev-db/sqlite:=
+ dev-libs/glib:2
+ dev-libs/protobuf:=
+ dev-libs/kdsingleapplication
+ dev-qt/qtbase:6=[concurrent,dbus,gui,network,sql,sqlite,widgets]
+ media-libs/alsa-lib
+ media-libs/taglib
+ x11-libs/libX11
+ cdda? ( dev-libs/libcdio:= )
+ gstreamer? (
+ media-libs/chromaprint:=
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ )
+ ipod? ( media-libs/libgpod )
+ moodbar? ( sci-libs/fftw:3.0 )
+ mtp? ( media-libs/libmtp )
+ pulseaudio? ( media-libs/libpulse )
+ vlc? ( media-video/vlc )
+"
+# Note: sqlite driver of dev-qt/qtsql is bundled, so no sqlite use is required; check if this can be overcome someway;
+RDEPEND="${COMMON_DEPEND}
+ gstreamer? (
+ media-plugins/gst-plugins-meta:1.0
+ media-plugins/gst-plugins-soup:1.0
+ media-plugins/gst-plugins-taglib:1.0
+ )
+ mtp? ( gnome-base/gvfs[mtp] )
+ udisks? ( sys-fs/udisks:2 )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-cpp/gtest
+ dev-libs/boost
+"
+
+DOCS=( Changelog README.md )
+
+REQUIRED_USE="
+ cdda? ( gstreamer )
+ || ( gstreamer vlc )
+"
+
+src_prepare() {
+ plocale_find_changes "src/translations" "" ".po"
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # spotify is not in portage
+ local mycmakeargs=(
+ -DBUILD_WERROR=OFF
+ # avoid automagically enabling of ccache (bug #611010)
+ -DCCACHE_EXECUTABLE=OFF
+ -DENABLE_GIO=ON
+ -DLINGUAS="$(plocale_get_locales)"
+ -DENABLE_AUDIOCD="$(usex cdda)"
+ -DENABLE_GSTREAMER="$(usex gstreamer)"
+ -DENABLE_LIBGPOD="$(usex ipod)"
+ -DENABLE_LIBMTP="$(usex mtp)"
+ -DENABLE_LIBPULSE="$(usex pulseaudio)"
+ -DENABLE_MOODBAR="$(usex moodbar)"
+ -DENABLE_MUSICBRAINZ="$(usex gstreamer)"
+ -DENABLE_SONGFINGERPRINTING="$(usex gstreamer)"
+ -DENABLE_UDISKS2="$(usex udisks)"
+ -DENABLE_VLC="$(usex vlc)"
+ -DBUILD_WITH_QT6=ON
+ )
+
+ use !debug && append-cppflags -DQT_NO_DEBUG_OUTPUT
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if use gstreamer ; then
+ elog "Note that list of supported formats is controlled by media-plugins/gst-plugins-meta "
+ elog "USE flags. You may be interested in setting aac, flac, mp3, ogg or wavpack USE flags "
+ elog "depending on your preferences"
+ fi
+}