aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/partclone/partclone-9999.ebuild')
-rw-r--r--sys-block/partclone/partclone-9999.ebuild123
1 files changed, 71 insertions, 52 deletions
diff --git a/sys-block/partclone/partclone-9999.ebuild b/sys-block/partclone/partclone-9999.ebuild
index 18d7537..f551aa5 100644
--- a/sys-block/partclone/partclone-9999.ebuild
+++ b/sys-block/partclone/partclone-9999.ebuild
@@ -1,68 +1,87 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-EAPI=5
+EAPI=6
-AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools
+if [[ -z ${PV%%*9999} ]]; then
+ EGIT_REPO_URI="https://github.com/Thomas-Tsai/${PN}.git"
+ inherit git-r3
+else
+ inherit vcs-snapshot
+ MY_PV="5e00059"
+ [[ -n ${PV%%*_p*} ]] && MY_PV="${PV}"
+ SRC_URI="
+ mirror://githubcl/Thomas-Tsai/${PN}/tar.gz/${MY_PV} -> ${P}.tar.gz
+ "
+ RESTRICT="primaryuri"
+ KEYWORDS="~amd64 ~x86"
+fi
-inherit autotools-utils git-2
-
-DESCRIPTION="Back up and restore used-blocks of a partition"
-HOMEPAGE="http://partclone.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/Thomas-Tsai/partclone"
-EGIT_BRANCH="release"
+DESCRIPTION="Partition cloning tool"
+HOMEPAGE="https://partclone.org"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
-IUSE="+extfs +fat exfat hfsp jfs +ntfs reiserfs reiser4 ufs xfs f2fs nilfs2 minix vmfs btrfs"
+IUSE="
+apfs btrfs +e2fs exfat f2fs fat fuse hfs minix ncurses nilfs2 ntfs reiser4
+reiserfs static xfs
+"
-DEPEND="reiserfs? ( sys-fs/progsreiserfs )
- exfat? ( sys-fs/exfat-utils )
+RDEPEND="
+ dev-libs/openssl:*
+ e2fs? ( sys-fs/e2fsprogs )
+ btrfs? ( sys-apps/util-linux )
+ fuse? ( sys-fs/fuse:0 )
+ ncurses? ( sys-libs/ncurses:0 )
+ nilfs2? ( sys-fs/nilfs-utils )
ntfs? ( sys-fs/ntfs3g )
- extfs? ( sys-libs/e2fsprogs-libs )
- reiser4? ( sys-fs/reiser4progs )
reiserfs? ( sys-fs/progsreiserfs )
- xfs? ( sys-fs/xfsprogs )
- ufs? ( sys-fs/ufsutils )
- jfs? ( sys-fs/jfsutils )
- btrfs? ( sys-fs/btrfs-progs )
- nilfs2? ( >=sys-fs/nilfs-utils-2.1.5-r1 )
- f2fs? ( >=sys-libs/e2fsprogs-libs-1.42.13 )"
- # sys-libs/ncurses[tinfo]
-RDEPEND="${DEPEND}"
-
-DOCS=( AUTHORS ChangeLog NEWS README TODO )
-
-my_use_enable() {
- use $1 && echo --enable-$1
-}
+ reiser4? ( sys-fs/reiser4progs )
+ xfs? ( sys-apps/util-linux )
+ static? (
+ dev-libs/openssl:*[static-libs]
+ e2fs? (
+ sys-fs/e2fsprogs[static-libs]
+ sys-libs/e2fsprogs-libs[static-libs]
+ )
+ btrfs? ( sys-apps/util-linux[static-libs] )
+ fuse? ( sys-fs/fuse:0[static-libs] )
+ ncurses? ( sys-libs/ncurses:0[static-libs] )
+ nilfs2? ( sys-fs/nilfs-utils[static-libs] )
+ ntfs? ( sys-fs/ntfs3g[static-libs] )
+ reiserfs? ( sys-fs/progsreiserfs[static-libs] )
+ reiser4? ( sys-fs/reiser4progs[static-libs] )
+ )
+"
+DEPEND="
+ ${RDEPEND}
+"
+DOCS=( AUTHORS ChangeLog HACKING NEWS README.md TODO )
src_prepare() {
- sed -i '/SUBDIRS/s/tests//' "${S}/Makefile.am" || die
- sed -i 's/sizeof(badsector_magic)/(strlen(badsector_magic) + 1)/' "${S}/src/partclone.c" || die
- autotools-utils_src_prepare
+ default
+ eautoreconf
}
src_configure() {
- local myeconfargs=(
- $(my_use_enable extfs)
- $(my_use_enable fat)
- $(my_use_enable hfsp)
- $(my_use_enable jfs)
- $(my_use_enable ntfs)
- $(my_use_enable reiserfs)
- $(my_use_enable reiser4)
- $(my_use_enable ufs)
- $(my_use_enable xfs)
- $(my_use_enable f2fs)
- $(my_use_enable nilfs2)
- $(my_use_enable minix)
- $(my_use_enable vmfs)
- $(my_use_enable btrfs)
- )
- autotools-utils_src_configure
+ local myconf=(
+ $(use_enable e2fs extfs)
+ $(use_enable apfs)
+ $(use_enable btrfs)
+ $(use_enable exfat)
+ $(use_enable f2fs)
+ $(use_enable fat)
+ $(use_enable fuse)
+ $(use_enable hfs hfsp)
+ $(use_enable minix)
+ $(use_enable ncurses ncursesw)
+ $(use_enable nilfs2)
+ $(use_enable ntfs)
+ $(use_enable reiserfs)
+ $(use_enable reiser4)
+ $(use_enable static)
+ $(use_enable xfs)
+ )
+ econf "${myconf[@]}"
}