summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthoine Bourgeois <anthoine.bourgeois@gmail.com>2011-06-27 23:25:49 +0200
committerAnthoine Bourgeois <anthoine.bourgeois@gmail.com>2011-06-27 23:25:49 +0200
commit4b2ad0e87542bcdaf96b4bb4c10546e34e525ad6 (patch)
treecafa32c550de4810a131d5ddf28e75640a580181 /sys-apps/fakechroot
parent+fakeroot-1.16.ebuild (diff)
downloadaluco-4b2ad0e87542bcdaf96b4bb4c10546e34e525ad6.tar.gz
aluco-4b2ad0e87542bcdaf96b4bb4c10546e34e525ad6.tar.bz2
aluco-4b2ad0e87542bcdaf96b4bb4c10546e34e525ad6.zip
+fakechroot-2.12-r1.ebuild
EAPI 4 patch for test: +files/fakechroot-2.12-gentoo_fix_chroot_location_in_test.patch and remove restrict test
Diffstat (limited to 'sys-apps/fakechroot')
-rw-r--r--sys-apps/fakechroot/Manifest3
-rw-r--r--sys-apps/fakechroot/fakechroot-2.12-r1.ebuild31
-rw-r--r--sys-apps/fakechroot/files/fakechroot-2.12-gentoo_fix_chroot_location_in_test.patch88
3 files changed, 122 insertions, 0 deletions
diff --git a/sys-apps/fakechroot/Manifest b/sys-apps/fakechroot/Manifest
new file mode 100644
index 0000000..33338c6
--- /dev/null
+++ b/sys-apps/fakechroot/Manifest
@@ -0,0 +1,3 @@
+AUX fakechroot-2.12-gentoo_fix_chroot_location_in_test.patch 3475 RMD160 c74a3df50e2f7a79b7ba4e104b455a865ac83288 SHA1 bed4cdb0ed22c8255789fcdd89fd3211664bf824 SHA256 66520a01af063926aebbb42e923b55201cf014aa5b332365788a49260318f5d4
+DIST fakechroot_2.12.orig.tar.gz 352298 RMD160 34a8068f360720032c82c6c6635c165da4a7d89b SHA1 b2e32c4de64ba2f2d83f3ac7947f502afbaa1cd9 SHA256 05174cc9caa3ec84cd7515caeafd809a9411e13498f972a617bf3616463b5d2b
+EBUILD fakechroot-2.12-r1.ebuild 807 RMD160 6766fb4e5b718dcaabf9cbe180ff2d63cce6d72e SHA1 7c7b4bc53ca9b7cbc4c6972f621fd2e1d6666171 SHA256 6fcccc731ea51a3812a860284ff00b253204411fc3cabf6300c28591842fbf7e
diff --git a/sys-apps/fakechroot/fakechroot-2.12-r1.ebuild b/sys-apps/fakechroot/fakechroot-2.12-r1.ebuild
new file mode 100644
index 0000000..596ab7a
--- /dev/null
+++ b/sys-apps/fakechroot/fakechroot-2.12-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fakechroot/fakechroot-2.12.ebuild,v 1.1 2010/11/14 09:05:32 ssuominen Exp $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Provide a faked chroot environment without requiring root privileges"
+HOMEPAGE="http://fakechroot.alioth.debian.org/"
+SRC_URI="mirror://debian/pool/main/f/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo_fix_chroot_location_in_test.patch
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-dependency-tracking
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc NEWS README THANKS
+ find "${D}" -name '*.la' -exec rm -f '{}' +
+}
diff --git a/sys-apps/fakechroot/files/fakechroot-2.12-gentoo_fix_chroot_location_in_test.patch b/sys-apps/fakechroot/files/fakechroot-2.12-gentoo_fix_chroot_location_in_test.patch
new file mode 100644
index 0000000..6ad2548
--- /dev/null
+++ b/sys-apps/fakechroot/files/fakechroot-2.12-gentoo_fix_chroot_location_in_test.patch
@@ -0,0 +1,88 @@
+diff -ur fakechroot-2.12.orig//test/chroot.sh fakechroot-2.12/test/chroot.sh
+--- fakechroot-2.12.orig//test/chroot.sh 2011-06-27 22:29:30.780440922 +0200
++++ fakechroot-2.12/test/chroot.sh 2011-06-27 22:29:56.829440999 +0200
+@@ -10,7 +10,7 @@
+ fi
+
+ if [ $# -gt 0 ]; then
+- HOME=/root exec /usr/sbin/chroot $destdir "$@"
++ HOME=/root exec /bin/chroot $destdir "$@"
+ else
+- HOME=/root exec /usr/sbin/chroot $destdir $SHELL
++ HOME=/root exec /bin/chroot $destdir $SHELL
+ fi
+diff -ur fakechroot-2.12.orig//test/common.inc fakechroot-2.12/test/common.inc
+--- fakechroot-2.12.orig//test/common.inc 2011-06-27 22:29:30.780440922 +0200
++++ fakechroot-2.12/test/common.inc 2011-06-27 22:30:16.624441002 +0200
+@@ -26,7 +26,7 @@
+ export LD_PRELOAD
+
+ if ! which chroot >/dev/null; then
+- PATH=$PATH:/usr/sbin:/sbin
++ PATH=$PATH:/usr/sbin:/sbin:/bin
+ export PATH
+ fi
+
+diff -ur fakechroot-2.12.orig//test/febootstrap.sh fakechroot-2.12/test/febootstrap.sh
+--- fakechroot-2.12.orig//test/febootstrap.sh 2011-06-27 22:29:30.780440922 +0200
++++ fakechroot-2.12/test/febootstrap.sh 2011-06-27 22:30:58.494440999 +0200
+@@ -6,7 +6,7 @@
+ export PATH=$srcdir/bin:$PATH
+
+ run () {
+- HOME=/root fakechroot /usr/sbin/chroot $destdir "$@"
++ HOME=/root fakechroot /bin/chroot $destdir "$@"
+ }
+
+ vendor=${VENDOR:-`lsb_release -s -i | tr 'A-Z' 'a-z'`}
+@@ -26,7 +26,7 @@
+ rm -rf $destdir
+
+ if ! which chroot >/dev/null; then
+- PATH=$PATH:/usr/sbin:/sbin
++ PATH=$PATH:/usr/sbin:/sbin:/bin
+ export PATH
+ fi
+
+@@ -45,8 +45,8 @@
+ rm -fv $destdir/etc/yum.repos.d/*update*.repo
+ sed -i 's/^enabled=0/enabled=1/' $destdir/etc/yum.repos.d/*.repo
+
+-HOME=/root fakeroot fakechroot /usr/sbin/chroot $destdir yum -y update
+-HOME=/root fakeroot fakechroot /usr/sbin/chroot $destdir yum -y install fakeroot gcc gettext make rpm-build yum-utils
++HOME=/root fakeroot fakechroot /bin/chroot $destdir yum -y update
++HOME=/root fakeroot fakechroot /bin/chroot $destdir yum -y install fakeroot gcc gettext make rpm-build yum-utils
+
+ run fakeroot sh -c 'cd /tmp && yumdownloader --source hello'
+ run sh -c 'mkdir -p /root/rpmbuild/SOURCES && cd /root/rpmbuild/SOURCES && rpm2cpio /tmp/hello-*.src.rpm | cpio -idmv "*.tar.gz"'
+diff -ur fakechroot-2.12.orig//test/t/chroot.t fakechroot-2.12/test/t/chroot.t
+--- fakechroot-2.12.orig//test/t/chroot.t 2011-06-27 22:29:30.780440922 +0200
++++ fakechroot-2.12/test/t/chroot.t 2011-06-27 22:31:13.889440983 +0200
+@@ -15,7 +15,7 @@
+ else
+
+ for testtree in testtree /testtree ./testtree /./testtree testtree/. testtree/./.; do
+- t=`$srcdir/$chroot.sh testtree /usr/sbin/chroot $testtree /bin/cat /CHROOT`
++ t=`$srcdir/$chroot.sh testtree /bin/chroot $testtree /bin/cat /CHROOT`
+ test "$t" = "testtree/testtree" || not
+ ok "$chroot chroot $testtree:" $t
+ done
+diff -ur fakechroot-2.12.orig//test/testtree.sh fakechroot-2.12/test/testtree.sh
+--- fakechroot-2.12.orig//test/testtree.sh 2011-06-27 22:29:30.780440922 +0200
++++ fakechroot-2.12/test/testtree.sh 2011-06-27 22:31:33.139441000 +0200
+@@ -37,6 +37,7 @@
+ '/bin/busybox' \
+ '/bin/cat' \
+ '/bin/chmod' \
++ '/bin/chroot' \
+ '/bin/csh' \
+ '/bin/cp' \
+ '/bin/echo' \
+@@ -62,7 +63,6 @@
+ '/usr/bin/seq' \
+ '/usr/bin/strace' \
+ '/usr/bin/touch' \
+- '/usr/sbin/chroot' \
+ '/usr/local/bin/bash' \
+ '/usr/local/bin/gseq' \
+ '/usr/local/bin/ltrace' \