aboutsummaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorNicholas Fish <gentoo@seaofdirac.net>2016-02-04 19:28:03 +0100
committerNicholas Fish <gentoo@seaofdirac.net>2016-02-04 19:28:03 +0100
commit4770d47a5806194cc3edbd151619ae156cd38035 (patch)
tree1d98d419f59df793bbe882dd3d3ed561f67ca5f8 /sys-fs
parentWorking Firefox-44 ebuild, however, as with the Thunderbird ebuild, it has a ... (diff)
downloadennui-4770d47a5806194cc3edbd151619ae156cd38035.tar.gz
ennui-4770d47a5806194cc3edbd151619ae156cd38035.tar.bz2
ennui-4770d47a5806194cc3edbd151619ae156cd38035.zip
Add fstrimDaemon ebuild (copied from Gentoo ARM overlay)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fstrimDaemon/Manifest1
-rw-r--r--sys-fs/fstrimDaemon/fstrimDaemon-9999.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/sys-fs/fstrimDaemon/Manifest b/sys-fs/fstrimDaemon/Manifest
new file mode 100644
index 0000000..060cf31
--- /dev/null
+++ b/sys-fs/fstrimDaemon/Manifest
@@ -0,0 +1 @@
+EBUILD fstrimDaemon-9999.ebuild 769 SHA256 260ac0a8c2c1f7ec079f4d784b2b9f8781828afa4477327776f267f88bb17244 SHA512 872c2a76d23be97d8efa41ca5d58a96821b5183532cd11824bdb0098c2e305e94a09e186b766ac59cc8cb5215cfba5bc3926b4d45887587ed95c4ad66e82f70e WHIRLPOOL 8bbeee7440cb587eabd25732cdfa908e94ce2b39123ae1b9e3cf5f33edf4a2524fd852371340f8b89e67d2f65c846769e94d96fc13f9ce7ca8ff18b6ce7b4bfe
diff --git a/sys-fs/fstrimDaemon/fstrimDaemon-9999.ebuild b/sys-fs/fstrimDaemon/fstrimDaemon-9999.ebuild
new file mode 100644
index 0000000..e24f85d
--- /dev/null
+++ b/sys-fs/fstrimDaemon/fstrimDaemon-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+EGIT_REPO_URI="https://github.com/dobek/fstrimDaemon.git"
+
+inherit git-2
+
+DESCRIPTION="Shell script daemon for fstrim to maintain ssd drive performance"
+HOMEPAGE="https://github.com/dobek/fstrimDaemon"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="systemd"
+
+RDEPEND="sys-apps/util-linux"
+
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dosbin usr/sbin/fstrimDaemon.sh
+ dodoc README.md
+ if ! use systemd ; then
+ doinitd etc/init.d/fstrimDaemon
+ doconfd etc/conf.d/fstrimDaemon
+ else
+ systemd_dounit usr/lib/systemd/system/fstrimDaemon.service
+ fi
+}
+