summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoreroen <eroen@falcon.eroen.eu>2014-12-12 11:11:52 +0100
committereroen <eroen@falcon.eroen.eu>2014-12-14 11:06:51 +0100
commitb199e1ea9bbd2ee9cd9201957a4585e2bff2b928 (patch)
tree462e0af6f61c21125175a72e843f8e6d16738c5a /games-action
parentkdebase-meta - make consolekit optional (diff)
downloaderoen-b199e1ea9bbd2ee9cd9201957a4585e2bff2b928.tar.gz
eroen-b199e1ea9bbd2ee9cd9201957a4585e2bff2b928.tar.bz2
eroen-b199e1ea9bbd2ee9cd9201957a4585e2bff2b928.zip
unepic-15005 - new ebuild
Diffstat (limited to 'games-action')
-rw-r--r--games-action/unepic/Manifest1
-rw-r--r--games-action/unepic/metadata.xml7
-rw-r--r--games-action/unepic/unepic-15005.ebuild84
3 files changed, 92 insertions, 0 deletions
diff --git a/games-action/unepic/Manifest b/games-action/unepic/Manifest
new file mode 100644
index 0000000..b56cd3c
--- /dev/null
+++ b/games-action/unepic/Manifest
@@ -0,0 +1 @@
+DIST unepic-15005-bin-installer-32.run 323583549 SHA256 11866de3bfdcac950c5bc29b6b5ff807e64307afef0b7f642378ccfcf2a073c8 SHA512 1a63273248bfd77763723c8f9c0e6bdef9531b87ffd979eb9e3e7930076c5d2b2d72a1c9a3ef5c12692b8c33ad4eb03b76235bdddf9ceba7970a6e5734f1ba08 WHIRLPOOL 9fdc0727a2764e30f84a9765be6dad311eb1741bdde539a9db130e1180d5040cbc11366e8a70a23c19304409219af3c64ed0674c3c2a1c3d7551849e7b311aa7
diff --git a/games-action/unepic/metadata.xml b/games-action/unepic/metadata.xml
new file mode 100644
index 0000000..7de7ddf
--- /dev/null
+++ b/games-action/unepic/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+ User configuration goes in '~/.local/share/Unepic/unepic'.
+ </longdescription>
+</pkgmetadata>
diff --git a/games-action/unepic/unepic-15005.ebuild b/games-action/unepic/unepic-15005.ebuild
new file mode 100644
index 0000000..b2f8e37
--- /dev/null
+++ b/games-action/unepic/unepic-15005.ebuild
@@ -0,0 +1,84 @@
+# By eroen, 2014
+#
+# Permission to use, copy, modify, and/or distribute this software for any
+# purpose with or without fee is hereby granted, provided that the above
+# copyright notice and this permission notice appear in all copies.
+#
+# $Header: $
+
+EAPI=5
+
+inherit eutils games
+
+DESCRIPTION="Combination of platforming and role playing game with many hilarious references"
+HOMEPAGE="http://www.unepicgame.com/en/game.html"
+# 308.6 MB
+# 2014-12-08 17:46
+# 940824c4de6e48522845f63423e87783
+SRC_URI="${P}-bin-installer-32.run"
+S=${WORKDIR}
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64" # ~x86
+IUSE=""
+
+LIBDEPEND="
+ sys-libs/zlib
+ virtual/opengl
+ sys-devel/gcc[cxx]
+ "
+HDEPEND="
+ app-admin/chrpath
+ "
+DEPEND="${HDEPEND}"
+RDEPEND="${LIBDEPEND}"
+
+MY_PREFIX=${GAMES_PREFIX_OPT}/${P}
+QA_PRESTRIPPED=${MY_PREFIX}/data/unepic.\*
+
+pkg_setup() {
+ use amd64 && bitness=64
+ #use x86 && bitness=32
+}
+
+src_unpack() {
+ local srcdir=${DISTDIR}/
+ local x=${A}
+ local myfail="failure unpacking ${x}"
+ # from phase-helpers.sh
+ ( set +x ; while true ; do echo n || break ; done ) | \
+ unzip -qo "${srcdir}${x}"
+ [[ $? = 0 ]] || [[ $? = 1 ]] || die "$myfail"
+}
+
+src_prepare() {
+ rm -rf "${S}"/guis/ || die
+ rm -f "${S}"/data/unepic.sh || die
+ rm -f "${S}"/data/lib*/libGLEW.so* || die
+ # dlopen: libSDL2_mixer-2.0.so.0 -> libvorbisfile.so.3
+
+ for x in "${S}"/data/*{32,64}; do
+ if [[ ${x} != *${bitness} ]]; then
+ rm -rf "${x}" || die "failed to remove ${x}"
+ fi
+ done
+
+ chrpath -d "${S}"/data/unepic${bitness} || die
+ chrpath -d "${S}"/data/lib${bitness}/libSDL2-2.0.so.0 || die
+}
+
+src_install() {
+ insinto "${MY_PREFIX}"
+ doins -r "${S}"/*
+
+ # exe: data/unepic${bitness}
+ # CWD: data/
+ # LD_LIBRARY_PATH: data/$(get_libdir)
+ games_make_wrapper ${PN} "${MY_PREFIX}"/data/unepic${bitness} \
+ "${MY_PREFIX}"/data "${MY_PREFIX}"/data/lib${bitness}
+ make_desktop_entry ${PN} Unepic "${MY_PREFIX}"/data/unepic.png
+
+ prepgamesdirs
+ fperms ug+x "${MY_PREFIX}"/data/unepic${bitness}
+}