summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoreroen <eroen@occam.eroen.eu>2013-06-24 02:07:22 +0200
committereroen <eroen@occam.eroen.eu>2013-06-24 02:07:22 +0200
commit407edb7ded5ccf5a1b5d7685bfd235d879a0e2b7 (patch)
tree66241e54dea9970e17cd41c305dd2645602a1dd9 /media-libs/libpng/libpng-1.6.2-r1.ebuild
parentelx86-baselibs - filter libpng (diff)
downloaderoen-407edb7ded5ccf5a1b5d7685bfd235d879a0e2b7.tar.gz
eroen-407edb7ded5ccf5a1b5d7685bfd235d879a0e2b7.tar.bz2
eroen-407edb7ded5ccf5a1b5d7685bfd235d879a0e2b7.zip
libpng-1.6.2-r1 from gentoo
Diffstat (limited to 'media-libs/libpng/libpng-1.6.2-r1.ebuild')
-rw-r--r--media-libs/libpng/libpng-1.6.2-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-libs/libpng/libpng-1.6.2-r1.ebuild b/media-libs/libpng/libpng-1.6.2-r1.ebuild
new file mode 100644
index 0000000..355b42e
--- /dev/null
+++ b/media-libs/libpng/libpng-1.6.2-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libpng/libpng-1.6.2-r1.ebuild,v 1.1 2013/06/23 17:49:58 ssuominen Exp $
+
+EAPI=5
+
+inherit eutils libtool multilib-minimal
+
+DESCRIPTION="Portable Network Graphics library"
+HOMEPAGE="http://www.libpng.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz
+ apng? ( mirror://sourceforge/apng/${P}-apng.patch.gz )"
+
+LICENSE="libpng"
+SLOT="0/16"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="apng neon static-libs"
+
+RDEPEND=">=sys-libs/zlib-1.2.8-r1:=[abi_x86_32?]
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-baselibs-20130224 )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-noexecstack.patch #465010#c39
+
+ if use apng; then
+ epatch "${WORKDIR}"/${PN}-*-apng.patch
+ # Don't execute symbols check with apng patch wrt #378111
+ sed -i -e '/^check/s:scripts/symbols.chk::' Makefile.in || die
+ fi
+ elibtoolize
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ --enable-arm-neon=$(usex neon on off)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ dodoc ANNOUNCE CHANGES libpng-manual.txt README TODO
+ prune_libtool_files --all
+}