summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhaarp <main.haarp@gmail.com>2020-03-11 14:09:13 +0100
committerhaarp <main.haarp@gmail.com>2020-03-27 22:31:03 +0100
commit9784b4954f69f7295ae522037fb7246fa3fdcb08 (patch)
tree8f84bf5bf8fa78850bbadc9b13db885f6fea6fe1
parentAdd libnacl with Python 2 support, needed by Salt with Python 2 support (diff)
downloadhaarp-9784b4954f69f7295ae522037fb7246fa3fdcb08.tar.gz
haarp-9784b4954f69f7295ae522037fb7246fa3fdcb08.tar.bz2
haarp-9784b4954f69f7295ae522037fb7246fa3fdcb08.zip
Fix xed Python stuff again, hopefully
I've no idea what I'm doing. I'm just whacking stuff until it stops complaining :( Signed-off-by: haarp <main.haarp@gmail.com>
-rw-r--r--app-editors/xed/Manifest2
-rw-r--r--app-editors/xed/xed-2.4.2.ebuild4
2 files changed, 3 insertions, 3 deletions
diff --git a/app-editors/xed/Manifest b/app-editors/xed/Manifest
index 3e4dfcb..9727337 100644
--- a/app-editors/xed/Manifest
+++ b/app-editors/xed/Manifest
@@ -1,2 +1,2 @@
DIST xed-2.4.2.tar.gz 4029991 BLAKE2B b8e745564017d27e7397885fa7cf2e76462660bb7d177dbc1fdd7a74f114334631d56fb2fb6835eff39f96a505eedac815986c3e4aa3d5dc9aea449eac8a74aa SHA512 9e448407b322348228037595f482b92afae8d45f1097d7be9598064053e21f7e515d8baf900bc06daccace0cfcbf71b8d709498f3a000ba47b61574090dac077
-EBUILD xed-2.4.2.ebuild 2081 BLAKE2B 1a0ab66c4510db0a0626f0bb7d86fb00414804d6adea17448a527f09bc049751333085ee541e7776b38ee58ce2860f0e4a4b7dd68883799420972ce69c63603b SHA512 130151555a506753ade85a2ac960332ada21742f0e80d5709ce794af733befc90fff6aa24b20c13a7d59a4366cddae4be61132f3df5215bb17b59eb759603cb7
+EBUILD xed-2.4.2.ebuild 2084 BLAKE2B 0218b9c2fdbc392e56620a5b9edcc89bfe7e496f3d6c6241e057c5d22e2df89d59d7fba9db25eec5e8771faa5163dee988dc095ff9a3ba7e705fa31208860bf0 SHA512 3fa02b55d4f691c3bb7c00f2d1cb249efd26e703c68e8785aebd81b2223b6270cf4cea570e781e99f48ccf0971fedbb911a9b5dbf32032b1b61a7d5c5d643e81
diff --git a/app-editors/xed/xed-2.4.2.ebuild b/app-editors/xed/xed-2.4.2.ebuild
index f1f3177..a19bdd6 100644
--- a/app-editors/xed/xed-2.4.2.ebuild
+++ b/app-editors/xed/xed-2.4.2.ebuild
@@ -3,7 +3,7 @@
EAPI="6"
GNOME2_LA_PUNT="yes" # plugins are dlopened
-PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit eutils gnome2 meson multilib python-single-r1
@@ -41,7 +41,7 @@ COMMON_DEPEND="
$(python_gen_cond_dep '
dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
>=dev-python/pygobject-3:3[cairo,${PYTHON_MULTI_USEDEP}]
- dev-libs/libpeas[${PYTHON_MULTI_USEDEP}]
+ dev-libs/libpeas[${PYTHON_SINGLE_USEDEP}]
')
)