summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/scripttest/scripttest-1.1.ebuild')
-rw-r--r--dev-python/scripttest/scripttest-1.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/scripttest/scripttest-1.1.ebuild b/dev-python/scripttest/scripttest-1.1.ebuild
new file mode 100644
index 0000000..d6b8c54
--- /dev/null
+++ b/dev-python/scripttest/scripttest-1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+# Ebuild generated by g-pypi 0.1
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+MY_PN="ScriptTest"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Helper to test command-line scripts"
+HOMEPAGE="http://pythonpaste.org/scripttest/"
+SRC_URI="http://pypi.python.org/packages/source/S/ScriptTest/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="test unittest doctest command line scripts"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND="dev-python/setuptools
+ test? ( dev-python/nose )"
+
+S="${WORKDIR}/${MY_P}"
+