aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pillow/pillow-2.0.0.ebuild')
-rw-r--r--dev-python/pillow/pillow-2.0.0.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/dev-python/pillow/pillow-2.0.0.ebuild b/dev-python/pillow/pillow-2.0.0.ebuild
deleted file mode 100644
index ac0728d..0000000
--- a/dev-python/pillow/pillow-2.0.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2} )
-
-inherit distutils-r1
-
-MY_PN="Pillow"
-
-DESCRIPTION="The friendly Python Imaging Library fork by Alex Clark and Contributors"
-HOMEPAGE="http://github.com/python-imaging/Pillow"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.zip -> ${P}.zip"
-
-KEYWORDS="~amd64 ~x86"
-IUSE="doc ext sane examples"
-LICENSE="PIL"
-SLOT="0"
-
-RDEPEND=">=media-libs/jpeg-6a
- >=media-libs/freetype-2.4.9
- >=media-libs/lcms-1.1.5"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-#S=${WORKDIR}/${P/pil/PIL}
-
-python_compile() {
- do_build() {
- if use ext; then
- "${PYTHON}" setup.py build_ext -i
- fi
-
- if use sane; then
- pushd Sane > /dev/null
- PYTHONPATH=. "$(PYTHON)" setup.py build
- popd > /dev/null
- fi
- "${PYTHON}" setup.py build
- }
- do_build
-}
-
-src_test() {
- testing() {
- PYTHONPATH="${S}"/ "$(PYTHON)" selftest.py
- }
- python_execute_function testing
-}
-
-python_install() {
-# do_sane() {
-# insinto $(python_get_sitedir)/PIL/
-# doins $(find Sane -name _sane.so)
-# doins $(find Sane -name sane.py)
-# chmod +x "${ED}"$(python_get_sitedir)/PIL/_sane.so || die
-# }
-# use sane && do_sane
- use doc && dohtml -r Docs/
- if use examples; then
- insinto use/share/doc/${P}/demo
- doins Sane/demo*.py
- fi
-}