aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2019-11-02 18:56:12 +0000
committerPaul Healy <lmiphay@gmail.com>2019-11-02 18:56:12 +0000
commit2f2169f876ca991d8d654bc25ff7376e394f054d (patch)
treebb287fbcc323eef94a6730339d41d051e72aa331 /www-apps
parentremove old ebuild (diff)
downloadlmiphay-2f2169f876ca991d8d654bc25ff7376e394f054d.tar.gz
lmiphay-2f2169f876ca991d8d654bc25ff7376e394f054d.tar.bz2
lmiphay-2f2169f876ca991d8d654bc25ff7376e394f054d.zip
rebump gitea
Signed-off-by: Paul Healy <lmiphay@gmail.com>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/gitea/Manifest2
-rw-r--r--www-apps/gitea/gitea-1.9.5.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/www-apps/gitea/Manifest b/www-apps/gitea/Manifest
index af2b362..6cfff60 100644
--- a/www-apps/gitea/Manifest
+++ b/www-apps/gitea/Manifest
@@ -4,4 +4,6 @@ AUX gitea.initd-r1 688 BLAKE2B eb2341dee53f3fd92c49137855615d9ae7ca77efc396e2d2e
AUX gitea.logrotated 87 BLAKE2B 373830ddd6eed0ce2f0f7b1dab14e4a253e5a56a73f477cfadbc6deec373846d4df2d697735391581771699d5a6513acb0e14a446873de01eba10d19e3a6bd88 SHA512 798f3fc33026f19dd31ffa78b9b1ed313d7b82b19c047f509e896c1798b2925a1bb7c4998d98a6b47e728979bf7132fb1c2a80eb7fda096a763d6791631cb6d4
AUX gitea.service 472 BLAKE2B 4c728e2987d0c0a86e65d4b9c1a59f6193ff8a3f9b066991a06f495ad1c5586b3497c71fca1cce5b65f167af09343e7bf3215ee5e8fdefa539e384198d2d88d6 SHA512 6666fe3b4cdbb78a58db4a6bf47a15e6be9ab30b666c6eb77a9e8a002d8c0abd510fc75ef463a11ee6892ab12c98943774616072cb64fd9f2fa42ff8f676aa95
DIST gitea-1.9.4.tar.gz 25355645 BLAKE2B 69a7237f7bc2d6d90054e67faef110c2750cbca927c149f6c6b3394bef113494cda8f670809c4977c6c5e3c4ea7f609240952b262ea6c4a818c11d58945bc5d8 SHA512 a885567ffcc21ef821348be0b698b5f101bfc46b746603679441bee4c6abe34ea062bd0a2d5fb5c029ce26caa3b70a51c6d9088fdccebb44be74f1e523faf711
+DIST gitea-1.9.5.tar.gz 25355286 BLAKE2B 8b733651de64fcafa7b41a6fc812fcad8ac7311a7e7acc679ec7dab759175ec13a096902aece209a3fef31eefd3a99493e13f7c9792e1e41b5a1c3376680d3ca SHA512 f7a04d3bb37a33da15290355f3f02ff4c1b737e8458cf65f731c870ac9e452243b1fdacc5f74accf963fb00cdd200dd31191058eb1d6dda8b1033846a961c7d3
EBUILD gitea-1.9.4.ebuild 2281 BLAKE2B fffca35a2508c3b4b6e4c005e1651b267294322c29e359efda689f0531fd4161a492887a90d698a279f2eba79dfb7f6132656f8ae38955e7ae66db4071e24478 SHA512 2fa3e6e476a7fbd1178aa61ff15c1839b2946380f0f79c775b6873462473b3d15daa9b7abe5a3513a2733487ef77899a9dd912f2b391ff9e68e0c7c5007a1ab7
+EBUILD gitea-1.9.5.ebuild 2281 BLAKE2B fffca35a2508c3b4b6e4c005e1651b267294322c29e359efda689f0531fd4161a492887a90d698a279f2eba79dfb7f6132656f8ae38955e7ae66db4071e24478 SHA512 2fa3e6e476a7fbd1178aa61ff15c1839b2946380f0f79c775b6873462473b3d15daa9b7abe5a3513a2733487ef77899a9dd912f2b391ff9e68e0c7c5007a1ab7
diff --git a/www-apps/gitea/gitea-1.9.5.ebuild b/www-apps/gitea/gitea-1.9.5.ebuild
new file mode 100644
index 0000000..1fbe7d7
--- /dev/null
+++ b/www-apps/gitea/gitea-1.9.5.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit user systemd golang-build golang-vcs-snapshot
+
+EGO_PN="code.gitea.io/gitea"
+KEYWORDS="~amd64 ~arm ~arm64"
+
+DESCRIPTION="A painless self-hosted Git service, written in Go"
+HOMEPAGE="https://github.com/go-gitea/gitea"
+SRC_URI="https://github.com/go-gitea/gitea/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-go/go-bindata"
+RDEPEND="dev-vcs/git"
+
+pkg_setup() {
+ enewgroup git
+ enewuser git -1 /bin/bash /var/lib/gitea git
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/\"main.Version.*$/\"main.Version=${PV}\"/"\
+ -e "s/-ldflags '-s/-ldflags '/" \
+ -e "s/GOFLAGS := -i -v/GOFLAGS := -v -mod=vendor/" \
+ -e 's/ generate \$/ generate -mod=vendor \$/' \
+ src/${EGO_PN}/Makefile || die
+ sed -i '/go:generate go fmt bindata.go/d' src/${EGO_PN}/modules/options/options.go || die
+ sed -i '/go:generate go fmt bindata.go/d' src/${EGO_PN}/modules/public/public.go || die
+ sed -i '/go:generate go fmt bindata.go/d' src/${EGO_PN}/modules/templates/templates.go || die
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" emake -C src/${EGO_PN} generate
+ TAGS="bindata pam sqlite" LDFLAGS="" CGO_LDFLAGS="-fno-PIC" GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" emake -C src/${EGO_PN} build
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin gitea
+ insinto /var/lib/gitea/conf
+ newins custom/conf/app.ini.sample app.ini.example
+ popd || die
+ newinitd "${FILESDIR}"/gitea.initd-r1 gitea
+ newconfd "${FILESDIR}"/gitea.confd gitea
+ keepdir /var/log/gitea /var/lib/gitea/data
+ fowners -R git:git /var/log/gitea /var/lib/gitea/
+ systemd_dounit "${FILESDIR}/gitea.service"
+}
+
+pkg_postinst() {
+ if [[ ! -e "${EROOT}/var/lib/gitea/conf/app.ini" ]]; then
+ elog "No app.ini found, copying initial config over"
+ cp "${FILESDIR}"/app.ini "${EROOT}"/var/lib/gitea/conf/ || die
+ chown git:git /var/lib/gitea/conf/app.ini
+ else
+ elog "app.ini found, please check example file for possible changes"
+ ewarn "Please note that environment variables have been changed:"
+ ewarn "GITEA_WORK_DIR is set to /var/lib/gitea (previous value: unset)"
+ ewarn "GITEA_CUSTOM is set to '\$GITEA_WORK_DIR/custom' (previous: /var/lib/gitea)"
+ fi
+}