summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/vegastrike/vegastrike-9999.ebuild')
-rw-r--r--games-simulation/vegastrike/vegastrike-9999.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/games-simulation/vegastrike/vegastrike-9999.ebuild b/games-simulation/vegastrike/vegastrike-9999.ebuild
index f0ac9ea..f6be640 100644
--- a/games-simulation/vegastrike/vegastrike-9999.ebuild
+++ b/games-simulation/vegastrike/vegastrike-9999.ebuild
@@ -42,8 +42,8 @@ S="${WORKDIR}"
pkg_setup() {
games_pkg_setup
if ! use gtk; then
- ewarn "Without USE=gtk vssetup will not be built."
- ewarn "You will have to manually edit ~/.vegastrike/vegastrike.config."
+ ewarn "Without USE=gtk vssetup will not get built. You will"
+ ewarn "have to manually edit ~/.vegastrike/vegastrike.config."
fi
# FIXME: is this still a problem?
@@ -60,7 +60,8 @@ src_unpack() {
if [ ! -d "${svn}/vegastrike" ]; then
ESVN_MODULE="vegastrike"
ESVN_MODULE_DIR="${ESVN_REPO_URI}/${ESVN_MODULE}"
- subversion_fetch $ESVN_MODULE_DIR $ESVN_MODULE || die "Fetching vegastrike failed"
+ subversion_fetch $ESVN_MODULE_DIR $ESVN_MODULE || \
+ die "Fetching vegastrike failed"
fi
einfo "Copying source to work directory..."
@@ -157,9 +158,11 @@ EOF
|| die "Creation of mesher failed"
newgamesbin vegastrike/vssetup vssetup \
- || ewarn "vssetup was not built. You will have to manually edit ~/.vegastrike/vegastrike.config."
+ || { ewarn "vssetup was not built. You will have to"; \
+ ewarn "manually edit ~/.vegastrike/vegastrike.config."; }
- make_desktop_entry "vegastrike" "Vegastrike" "${GAMES_DATADIR}/${PN}/data/vegastrike.xpm"
+ make_desktop_entry "vegastrike" "Vegastrike" \
+ "${GAMES_DATADIR}/${PN}/data/vegastrike.xpm"
prepgamesdirs
}
@@ -167,7 +170,7 @@ EOF
pkg_postinst() {
games_pkg_postinst
einfo "First run vsinstall to install your account into ~/.vegastrike,"
- if use gtk; then
+ if [ -e "${GAMES_BINDIR}/vssetup" ]; then
einfo "then run vssetup to configure Vega Strike."
else
einfo "then edit ~/.vegastrike/vegastrike.config."