summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPalmer Dabbelt <palmer@dabbelt.com>2019-05-07 17:03:24 -0700
committerPalmer Dabbelt <palmer@dabbelt.com>2019-05-07 17:05:39 -0700
commitc708b20ef104188e90f33ce920b897a10368ea56 (patch)
tree3393fda6a34c0da9e3ded0562dcfb5d8a342dfc2
parentI had a dirty old pconfigure (diff)
downloadpalmer-c708b20ef104188e90f33ce920b897a10368ea56.tar.gz
palmer-c708b20ef104188e90f33ce920b897a10368ea56.tar.bz2
palmer-c708b20ef104188e90f33ce920b897a10368ea56.zip
Everyone else has thin manifests!
Signed-off-by: Palmer Dabbelt <palmer@dabbelt.com>
-rw-r--r--gui-apps/kanshi/.kanshi-20190201.ebuild.swpbin0 -> 12288 bytes
-rw-r--r--gui-apps/kanshi/Manifest2
-rw-r--r--gui-apps/kanshi/kanshi-20190201.ebuild47
-rw-r--r--metadata/layout.conf1
4 files changed, 50 insertions, 0 deletions
diff --git a/gui-apps/kanshi/.kanshi-20190201.ebuild.swp b/gui-apps/kanshi/.kanshi-20190201.ebuild.swp
new file mode 100644
index 0000000..25aa80d
--- /dev/null
+++ b/gui-apps/kanshi/.kanshi-20190201.ebuild.swp
Binary files differ
diff --git a/gui-apps/kanshi/Manifest b/gui-apps/kanshi/Manifest
new file mode 100644
index 0000000..4520388
--- /dev/null
+++ b/gui-apps/kanshi/Manifest
@@ -0,0 +1,2 @@
+DIST kanshi-20190201.tar.gz 8101 BLAKE2B 069bd368d607d090c7052728f079c11b989e74771d1e064f9f94efc1296cfc88d814acad70830dc99028086c2497704025c942c60dbccf4323d09da0950a7dbe SHA512 181d54b4d3c247b832f2dc4af05732294b0068e279420e9d7409a0393321508e872ccccd97281b3d472adadc7f532ae688bf52697d4d1be39683b8dcd2f152da
+EBUILD kanshi-20190201.ebuild 772 BLAKE2B bea082efbb69a18e44f14e888bda1ad9b599c76dfa89e02813501550d83422e5932cb353e3a6e969cfa96d216be52fbd091f907fa9f9d7b46db402b5051c4dd7 SHA512 1eb1833ba25d332f563a21128ce95b9fa83d236dd6cdbc4944e53e6315b8ad5b8997ce23871ec71a6d1d6424e6f2f7791b12af80051d80d800a972fc9ee7d603
diff --git a/gui-apps/kanshi/kanshi-20190201.ebuild b/gui-apps/kanshi/kanshi-20190201.ebuild
new file mode 100644
index 0000000..cad7f47
--- /dev/null
+++ b/gui-apps/kanshi/kanshi-20190201.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CRATES="
+bitflags-1.0.4
+byteorder-1.2.7
+cfg-if-0.1.6
+edid-0.2.0
+getopts-0.2.18
+i3ipc-0.8.4
+itoa-0.4.3
+libc-0.2.43
+libudev-0.2.0
+libudev-sys-0.1.4
+log-0.3.9
+log-0.4.6
+memchr-1.0.2
+nom-3.2.1
+pkg-config-0.3.14
+ryu-0.2.7
+serde-1.0.80
+serde_json-1.0.33
+unicode-width-0.1.5
+xml-rs-0.7.0
+xmltree-0.8.0
+"
+
+inherit cargo
+
+GIT_HASH="970267e400c21a6bb51a1c80a0aadfd1e6660a7b"
+
+DESCRIPTION="Dynamic display manager"
+HOMEPAGE="https://github.com/emersion/kanshi"
+SRC_URI="http://github.com/emersion/kanshi/archive/${GIT_HASH}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/${PN}-${GIT_HASH}"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
diff --git a/metadata/layout.conf b/metadata/layout.conf
index d43e61c..ca9fee1 100644
--- a/metadata/layout.conf
+++ b/metadata/layout.conf
@@ -1 +1,2 @@
masters = gentoo
+thin-manifests = true