summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/tlenlinux/tlenlinux-7.0.1.25.ebuild')
-rw-r--r--net-im/tlenlinux/tlenlinux-7.0.1.25.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/net-im/tlenlinux/tlenlinux-7.0.1.25.ebuild b/net-im/tlenlinux/tlenlinux-7.0.1.25.ebuild
new file mode 100644
index 0000000..99febce
--- /dev/null
+++ b/net-im/tlenlinux/tlenlinux-7.0.1.25.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Tlen IM client"
+HOMEPAGE="http://tlen.pl"
+SRC_URI="
+ amd64? ( http://j.o2.pl/idi/${PN}64-${PV}.bin )
+ x86? ( http://j.o2.pl/idi/${P}.bin )"
+
+LICENSE="tlen"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="phonon"
+PROPERTIES="interactive"
+RESTRICT="strip"
+
+RDEPEND="x11-libs/qt-gui:4
+ phonon? ( x11-libs/qt-phonon:4 )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+TLEN_DIR="/opt/tlen"
+STATIC_FILES="./imageformats/* ./phonon_backend/* ./qt_libs/*"
+SHARED_FILES="tlen_libs/libgg.so tlen-bin updater"
+
+src_unpack() {
+ unpack_makeself
+ cd ${S}/data
+ # Fix RPATH
+ if use phonon; then
+ # Change RPATH
+ ./chrpath -r ${TLEN_DIR}/tlen_libs ${SHARED_FILES} > /dev/null
+ # Disable unset
+ sed -i "s:unset:# unset:" tlen
+ # Remove unneeded libs
+ rm -rf qt_libs imageformats phonon_backend
+ else
+ # Change RPATH
+ ./chrpath -r ${TLEN_DIR}/qt_libs:${TLEN_DIR}/tlen_libs ${SHARED_FILES} > /dev/null
+ ./chrpath -r ${TLEN_DIR}/qt_libs ${STATIC_FILES} > /dev/null
+ fi
+ # Desktop icon fix
+ sed -i "s:.jpg:.png:" ${S}/tlen.desktop
+}
+
+src_install() {
+ # Prepare directory
+ dodir ${TLEN_DIR}
+ # Copy data
+ cp -r data/* ${D}/${TLEN_DIR} || die "cp failed"
+ # Install desktop file
+ insinto /usr/share/applications/
+ doins tlen.desktop
+ # Install symlink
+ dodir /usr/bin
+ dosym ${TLEN_DIR}/tlen /usr/bin/tlen
+}
+
+pkg_preinst() {
+ check_license ${TLEN_DIR}/license.txt
+}
+
+pkg_postinst() {
+ ### @todo deactivate auto-update by default
+ elog "It is not recommended to use Updater plugin."
+ elog "You should deselect Updater in:,"
+ elog "\"Tlen\" -> \"Preferences\" -> \"Plugins\"."
+ elog
+}