summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/BaiduPCS-Go/BaiduPCS-Go-3.6.2.ebuild')
-rw-r--r--net-misc/BaiduPCS-Go/BaiduPCS-Go-3.6.2.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/net-misc/BaiduPCS-Go/BaiduPCS-Go-3.6.2.ebuild b/net-misc/BaiduPCS-Go/BaiduPCS-Go-3.6.2.ebuild
deleted file mode 100644
index 7ff3760..0000000
--- a/net-misc/BaiduPCS-Go/BaiduPCS-Go-3.6.2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-EGO_PN="github.com/iikira/${PN}"
-EGO_VENDOR=(
-)
-
-inherit golang-build golang-vcs-snapshot
-
-DESCRIPTION="BaiDu PCS client, written in GoLang"
-ARCHIVE_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- ${EGO_VENDOR_URI}"
-SRC_URI="${ARCHIVE_URI}"
-RESTRICT="mirror"
-
-LICENSE="MIT"
-SLOT="0/${PVR}"
-KEYWORDS="~amd64 ~x86 ~arm"
-IUSE="+pie"
-
-src_compile() {
- # -buildmode=pie forces external linking mode, even CGO_ENABLED=0
- # https://github.com/golang/go/issues/18968
- use pie && local build_pie="-buildmode=pie"
-
- local build_flags="$( echo ${EGO_BUILD_FLAGS} ) $( echo ${build_pie} )"
-
- set -- env GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
- GOCACHE="${T}/go-cache" \
- CGO_ENABLED=0 \
- GO111MODULE=off \
- go install -v -work -x ${build_flags} ${EGO_PN}
- echo "$@"
- "$@" || die
-}
-
-src_install() {
- newbin bin/${PN} baidu-pcs
-}