summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Labedan <plabedan@gmail.com>2015-02-28 08:39:58 +0100
committerPaul Labedan <plabedan@gmail.com>2015-02-28 08:39:58 +0100
commit09247268bdfb6554620b838a1edbbbbb73d297e2 (patch)
tree42f9ea280df26ab444605d98abc789611dfb1b87 /sys-devel
parentadd llvm 3.6.0 (diff)
downloadplab-09247268bdfb6554620b838a1edbbbbb73d297e2.tar.gz
plab-09247268bdfb6554620b838a1edbbbbb73d297e2.tar.bz2
plab-09247268bdfb6554620b838a1edbbbbb73d297e2.zip
add clang 3.6.0
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/Manifest2
-rw-r--r--sys-devel/clang/clang-3.6.0.ebuild35
-rw-r--r--sys-devel/clang/metadata.xml35
3 files changed, 72 insertions, 0 deletions
diff --git a/sys-devel/clang/Manifest b/sys-devel/clang/Manifest
new file mode 100644
index 0000000..f1ba28f
--- /dev/null
+++ b/sys-devel/clang/Manifest
@@ -0,0 +1,2 @@
+EBUILD clang-3.6.0.ebuild 1144 SHA256 cf9dec875c7e66d66e3e1af5e35e764ee1641d0f7870d19311ae523c470f31cc SHA512 f9f774174d0ad4a32c8aad77b0bf1bdbf3486ca027108e1fe8d165226184b8957e0343407002be09e991b3a3fd2aedd130243734197caec79b4b0a93da7163dc WHIRLPOOL 453c68bfb4d8e28c178fa5b6de4b96a8442662dd9a60a738da71f9a5ac22995efbaa0ec8a822e28aec26cc13dd27ea2a48bf926c92af60496c49e8966cc341c3
+MISC metadata.xml 1347 SHA256 ac44c316696ae0c3b3b10dd9b1529e4bad85b0a3d5f6ac2b0ec6b657f559451c SHA512 faf5c07813f2556cdca2967741dc68ad53d56584bf1570fd2d25289b889f9ce3c4fe503b7b0a7f0f2145f6244c7ae33ad0e7b24762c5de2794b1c7d565f36968 WHIRLPOOL 3fcc87924c756e6ffe507caacc112b7a1507bdd5dca1cc2e4f5b3251d9f34fd6bdfb28c76ada06ecf58abea8be5b41e19cf2d412e4b84c68b508e2d0758e008b
diff --git a/sys-devel/clang/clang-3.6.0.ebuild b/sys-devel/clang/clang-3.6.0.ebuild
new file mode 100644
index 0000000..b15737c
--- /dev/null
+++ b/sys-devel/clang/clang-3.6.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit multilib-build
+
+DESCRIPTION="C language family frontend for LLVM (meta-ebuild)"
+HOMEPAGE="http://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="UoI-NCSA"
+SLOT="0/3.5"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="debug multitarget python +static-analyzer"
+
+RDEPEND="~sys-devel/llvm-${PV}[clang(-),debug=,multitarget?,python?,static-analyzer,${MULTILIB_USEDEP}]"
+
+# Please keep this package around since it's quite likely that we'll
+# return to separate LLVM & clang ebuilds when the cmake build system
+# is complete.
+
+pkg_postinst() {
+ if has_version ">=dev-util/ccache-3.1.9-r2" ; then
+ #add ccache links as clang might get installed after ccache
+ "${EROOT}"/usr/bin/ccache-config --install-links
+ fi
+}
+
+pkg_postrm() {
+ if has_version ">=dev-util/ccache-3.1.9-r2" && [[ -z ${REPLACED_BY_VERSION} ]]; then
+ # --remove-links would remove all links, --install-links updates them
+ "${EROOT}"/usr/bin/ccache-config --install-links
+ fi
+}
diff --git a/sys-devel/clang/metadata.xml b/sys-devel/clang/metadata.xml
new file mode 100644
index 0000000..466ad97
--- /dev/null
+++ b/sys-devel/clang/metadata.xml
@@ -0,0 +1,35 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>clang@gentoo.org</email>
+ <name>Gentoo clang support project</name>
+ </maintainer>
+ <longdescription>The goal of the Clang project is to create a new C, C++, Objective C and Objective C++ front-end for the LLVM compiler.
+
+Features and Goals
+
+Some of the goals for the project include the following:
+
+End-User Features:
+Fast compiles and low memory use
+Expressive diagnostics
+GCC compatibility
+Utility and Applications:
+
+Modular library based architecture
+Support diverse clients (refactoring, static analysis, code generation, etc)
+Allow tight integration with IDEs
+Use the LLVM BSD License
+Internal Design and Implementation:
+
+A real-world, production quality compiler
+A simple and hackable code base
+A single unified parser for C, Objective C, C++, and Objective C++
+Conformance with C/C++/ObjC and their variants</longdescription>
+ <use>
+ <flag name='multitarget'>Build all host targets (default: host only)</flag>
+ <flag name='static-analyzer'>Install the Clang static analyzer</flag>
+ <flag name='system-cxx-headers'>By default, clang++ searchs for C++ headers in a series of hardcoded paths. Enabling this flag will force it to use the active gcc profile ones</flag>
+ </use>
+</pkgmetadata>