summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Bressler <ruben.bressler@cerpamid.co.cu>2010-07-19 21:22:12 -0400
committerRuben Bressler <ruben.bressler@cerpamid.co.cu>2010-07-19 21:22:12 -0400
commit752f4ec119229badc274a3019e044f8e5c82a513 (patch)
treebbbf0ea60003371127eef03f703d2727fc78e56b /app-arch
parentadicionando gtk+-2.21.5 (diff)
downloadrubenqba-752f4ec119229badc274a3019e044f8e5c82a513.tar.gz
rubenqba-752f4ec119229badc274a3019e044f8e5c82a513.tar.bz2
rubenqba-752f4ec119229badc274a3019e044f8e5c82a513.zip
adicionando de todo
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/file-roller/Manifest3
-rw-r--r--app-arch/file-roller/file-roller-2.31.4.ebuild71
-rw-r--r--app-arch/file-roller/files/file-roller-2.10.3-use_bin_tar.patch12
3 files changed, 86 insertions, 0 deletions
diff --git a/app-arch/file-roller/Manifest b/app-arch/file-roller/Manifest
new file mode 100644
index 0000000..c9e367c
--- /dev/null
+++ b/app-arch/file-roller/Manifest
@@ -0,0 +1,3 @@
+AUX file-roller-2.10.3-use_bin_tar.patch 504 RMD160 0af7af1c83953554e58c3a2f82ae3edb2e6b7e55 SHA1 a40077b5ace4be970dae46b44aa5b8ce19a75780 SHA256 c22e742893800c4302df40af66b1eabeab700fea7326eada849f919bdd76c052
+DIST file-roller-2.31.4.tar.bz2 1832150 RMD160 29f2915b88a4858eb90caa3095a18489d91b8a08 SHA1 960b73cfd8e9403a15b99a7f2de8a14f3429912a SHA256 be0310d57804c27bb4550298648ae5da350bd9e982f1b89d2a3939cd479f2a49
+EBUILD file-roller-2.31.4.ebuild 2016 RMD160 c6fa7feaf5ced8f43c980a69cdc4450a024a8ed0 SHA1 d13b0b847e6de599e0cfa637406796f1d3b72bdf SHA256 9b79a5ea5fc98b9d9a75db5ff73b79adbb3bdf3114352e58b4d0a387128da156
diff --git a/app-arch/file-roller/file-roller-2.31.4.ebuild b/app-arch/file-roller/file-roller-2.31.4.ebuild
new file mode 100644
index 0000000..8f35679
--- /dev/null
+++ b/app-arch/file-roller/file-roller-2.31.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/file-roller-2.30.1.1.ebuild,v 1.1 2010/06/13 19:22:40 pacho Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2
+
+DESCRIPTION="archive manager for GNOME"
+HOMEPAGE="http://fileroller.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+IUSE="nautilus"
+
+RDEPEND=">=dev-libs/glib-2.25.5
+ >=x11-libs/gtk+-2.19.7:2
+ >=gnome-base/gconf-2.6
+ nautilus? ( >=gnome-base/nautilus-2.22.2 )"
+DEPEND="${RDEPEND}
+ gnome-base/gnome-common
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ dev-util/pkgconfig
+ app-text/gnome-doc-utils"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-dependency-tracking
+ --disable-scrollkeeper
+ --disable-run-in-place
+ --disable-static
+ --disable-packagekit
+ $(use_enable nautilus nautilus-actions)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Use absolute path to GNU tar since star doesn't have the same
+ # options. On Gentoo, star is /usr/bin/tar, GNU tar is /bin/tar
+ epatch "${FILESDIR}"/${PN}-2.10.3-use_bin_tar.patch
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ elog "${PN} is a frontend for several archiving utilities. If you want a"
+ elog "particular achive format support, see ${HOMEPAGE}"
+ elog "and install the relevant package."
+ elog
+ elog "for example:"
+ elog " 7-zip - app-arch/p7zip"
+ elog " ace - app-arch/unace"
+ elog " arj - app-arch/arj"
+ elog " cpio - app-arch/cpio"
+ elog " deb - app-arch/dpkg"
+ elog " iso - app-cdr/cdrtools"
+ elog " jar,zip - app-arch/zip and app-arch/unzip"
+ elog " lha - app-arch/lha"
+ elog " lzma - app-arch/xz-utils"
+ elog " lzop - app-arch/lzop"
+ elog " rar - app-arch/unrar"
+ elog " rpm - app-arch/rpm"
+ elog " unstuff - app-arch/stuffit"
+ elog " zoo - app-arch/zoo"
+}
diff --git a/app-arch/file-roller/files/file-roller-2.10.3-use_bin_tar.patch b/app-arch/file-roller/files/file-roller-2.10.3-use_bin_tar.patch
new file mode 100644
index 0000000..edaa16c
--- /dev/null
+++ b/app-arch/file-roller/files/file-roller-2.10.3-use_bin_tar.patch
@@ -0,0 +1,12 @@
+diff -uNr file-roller-2.10.3/src/fr-command-tar.c file-roller-2.10.3.patched/src/fr-command-tar.c
+--- file-roller-2.10.3/src/fr-command-tar.c 2005-04-22 18:39:22.000000000 +0200
++++ file-roller-2.10.3.patched/src/fr-command-tar.c 2005-06-06 14:29:45.000000000 +0200
+@@ -225,7 +225,7 @@
+ if (command != NULL)
+ fr_process_begin_command (comm->process, command);
+ else
+- fr_process_begin_command (comm->process, "tar");
++ fr_process_begin_command (comm->process, "/bin/tar");
+ g_free (command);
+ }
+