summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/spacechem/spacechem-1012.ebuild')
-rw-r--r--games-puzzle/spacechem/spacechem-1012.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/games-puzzle/spacechem/spacechem-1012.ebuild b/games-puzzle/spacechem/spacechem-1012.ebuild
deleted file mode 100644
index ee3c1c6..0000000
--- a/games-puzzle/spacechem/spacechem-1012.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/darwinia-demo/darwinia-demo-1.3.0.ebuild,v 1.9 2009/05/22 21:47:48 mr_bones_ Exp $
-
-EAPI="2"
-
-inherit eutils games
-
-DESCRIPTION="A design-based puzzle game from Zachtronics Industries."
-HOMEPAGE="http://www.spacechemthegame.com/"
-
-MY_PV="1.0.12"
-
-SRC_URI="amd64? ( ${PN}-linux-1345144627-amd64.deb )
- x86? ( SpaceChem-i386.deb )"
-
-LICENSE="spacechem"
-SLOT="0"
-KEYWORDS="-* amd64 ~x86"
-IUSE=""
-RESTRICT="strip fetch"
-
-RDEPEND=">=dev-lang/mono-2.10.3
- x11-misc/xclip
- media-libs/libsdl
- media-libs/sdl-mixer
- media-libs/sdl-image
- dev-db/sqlite:3"
-
-S=${WORKDIR}
-
-GAMEDIR=${GAMES_PREFIX_OPT}/${PN}
-
-src_unpack() {
- unpack "${A}"
- tar -zxf "${S}/data.tar.gz"
-}
-
-src_install() {
- insinto "${GAMEDIR}"
- exeinto "${GAMEDIR}"
-
- # install icon
- newicon opt/zachtronicsindustries/spacechem/icon.png ${PN}.png \
- || die "install icon"
-
- # install docs
- dodoc opt/zachtronicsindustries/spacechem/readme/*
-
- # cleanup unneeded files
- rm opt/zachtronicsindustries/spacechem/*.{desktop,ico,png,sh}
- rm -rf opt/zachtronicsindustries/spacechem/readme
-
- # install game files
- doins -r opt/zachtronicsindustries/spacechem/* || die "doins opt"
-
- # install shortcuts
- games_make_wrapper "${PN}" "mono SpaceChem.exe" "${GAMEDIR}" "${GAMEDIR}" \
- || die "install shortcue"
- make_desktop_entry "${PN}" "SpaceChem" "${PN}" "Game;LogicGame;" "Comment=Solve design-based challenges in this game from Zachtronics Industries"
-
- prepgamesdirs
-
- #cd "${S}/usr/share/man/man6"
- #doman spacechem.6.gz
-}
-
-pkg_postinst() {
- einfo "To play the game, run:"
- einfo "${PN}"
- games_pkg_postinst
-}