aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/i3/i3-9999.ebuild')
-rw-r--r--x11-wm/i3/i3-9999.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/x11-wm/i3/i3-9999.ebuild b/x11-wm/i3/i3-9999.ebuild
deleted file mode 100644
index 0ed0edc..0000000
--- a/x11-wm/i3/i3-9999.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="4"
-
-EGIT_REPO_URI="git://code.stapelberg.de/i3"
-: ${EGIT_BRANCH:=next}
-
-inherit multilib git-2
-
-DESCRIPTION="An improved dynamic tiling window manager"
-HOMEPAGE="http://i3wm.org/"
-SRC_URI=""
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="debug doc +man"
-
-RDEPEND="
- dev-libs/libev
- dev-libs/yajl
- x11-libs/libX11
- >=x11-libs/libxcb-1.1.93
- x11-libs/libXcursor
- x11-libs/pango
- x11-libs/startup-notification
- >=x11-libs/xcb-util-0.3.8
- >=x11-libs/xcb-util-keysyms-0.3.8
- >=x11-libs/xcb-util-wm-0.3.8
- "
-DEPEND="${RDEPEND}
- dev-lang/perl
- dev-util/pkgconfig
- sys-devel/bison
- sys-devel/flex
- >=x11-proto/xcb-proto-1.3
- doc? ( >=app-text/asciidoc-8.3 )
- man? (
- >=app-text/asciidoc-8.3
- app-text/xmlto
- )
- "
-
-src_prepare() {
- use debug || { sed -i -e "s:DEBUG=1:DEBUG=0:" common.mk || die "sed die - debug" ; }
-}
-
-src_compile() {
- local targets=( all )
-
- use doc && targets+=( docs )
- use man && targets+=( mans )
-
- emake ${targets[@]}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- use man && doman man/*.1
- use doc && dohtml -r docs/*.html
-}