summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Solano Gómez <daniel@solanogomez.org>2016-06-19 23:38:59 -0500
committerDaniel Solano Gómez <daniel@solanogomez.org>2016-06-19 23:53:42 -0500
commitd109bf85b2f23c82b25dcc8d389f74dae8fcd0d6 (patch)
treeeba717bc37203d893566b0d3b4b3a08bef09b940 /app-backup
parentAdd amanda with swig fix (diff)
downloadsattvik-d109bf85b2f23c82b25dcc8d389f74dae8fcd0d6.tar.gz
sattvik-d109bf85b2f23c82b25dcc8d389f74dae8fcd0d6.tar.bz2
sattvik-d109bf85b2f23c82b25dcc8d389f74dae8fcd0d6.zip
Add tarsnap-1.0.37
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/tarsnap/Manifest2
-rw-r--r--app-backup/tarsnap/tarsnap-1.0.37.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/app-backup/tarsnap/Manifest b/app-backup/tarsnap/Manifest
new file mode 100644
index 0000000..50954d9
--- /dev/null
+++ b/app-backup/tarsnap/Manifest
@@ -0,0 +1,2 @@
+DIST tarsnap-autoconf-1.0.37.tgz 629450 SHA256 fa999413651b3bd994547a10ffe3127b4a85a88b1b9a253f2de798888718dbfa SHA512 050053f2109b74cda16511cf35ab2c11e0470ba745c661d254b7c17efde9e629830d519896b343dbd4f48ee739dfef47b724eb5e2e78c3e7dbc4ae018a536a5f WHIRLPOOL 7a5a3aa6e5a0f6790d1ca4903fbe4dab758c104b1cb713e748721e81aa3305d6d1dea755994468d3b26451441c077362c4a64757c2f4fab552fdd9efba9afaa1
+EBUILD tarsnap-1.0.37.ebuild 902 SHA256 e82f5ed8e9a1a5305740db934fa940bdd69e59219ac09927cc3c5fd3283acb86 SHA512 a12665961b8790b18867f9058105b0086e787c4466924d0042707e5512a5262ad18f5a024a0cc1d4763ab6cc8f9fdb8df57a37c1d3fbd4b30cd12119f0e13b10 WHIRLPOOL 2124302dec9aa4a14d7572e1c50590595ecf4dd5d6f1d9ae0a900fac2d03ace77ba582ef34ad43fde262589bad026dc73890c986877a9d43d2394b83788ae4e7
diff --git a/app-backup/tarsnap/tarsnap-1.0.37.ebuild b/app-backup/tarsnap/tarsnap-1.0.37.ebuild
new file mode 100644
index 0000000..d11f2f6
--- /dev/null
+++ b/app-backup/tarsnap/tarsnap-1.0.37.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Online backups for the truly paranoid"
+HOMEPAGE="http://www.tarsnap.com/"
+SRC_URI="https://www.tarsnap.com/download/${PN}-autoconf-${PV}.tgz"
+
+LICENSE="tarsnap"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="acl bzip2 libressl lzma cpu_flags_x86_sse2 xattr"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ sys-libs/e2fsprogs-libs
+ sys-libs/zlib
+ acl? ( sys-apps/acl )
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )
+ xattr? ( sys-apps/attr )"
+DEPEND="${RDEPEND}
+ virtual/os-headers" # Required for "magic.h"
+
+S=${WORKDIR}/${PN}-autoconf-${PV}
+
+src_configure() {
+ econf \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable xattr) \
+ $(use_enable acl) \
+ $(use_with bzip2 bz2lib) \
+ --without-lzmadec \
+ $(use_with lzma)
+}