summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Solano Gómez <daniel@solanogomez.org>2018-09-06 11:44:59 -0500
committerDaniel Solano Gómez <daniel@solanogomez.org>2018-09-06 11:44:59 -0500
commit6da09c88695cb47baa27bbc0894fbaa73298b7db (patch)
treed55e76f75b75eccdf5dd7591c29c608e178c45cc /app-emulation
parentAdd leiningen-bin-2.8.1 (diff)
downloadsattvik-6da09c88695cb47baa27bbc0894fbaa73298b7db.tar.gz
sattvik-6da09c88695cb47baa27bbc0894fbaa73298b7db.tar.bz2
sattvik-6da09c88695cb47baa27bbc0894fbaa73298b7db.zip
Add amazon-ecr-credential-helper-0.1.0
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/amazon-ecr-credential-helper/Manifest2
-rw-r--r--app-emulation/amazon-ecr-credential-helper/amazon-ecr-credential-helper-0.1.0.ebuild31
-rw-r--r--app-emulation/amazon-ecr-credential-helper/metadata.xml8
3 files changed, 41 insertions, 0 deletions
diff --git a/app-emulation/amazon-ecr-credential-helper/Manifest b/app-emulation/amazon-ecr-credential-helper/Manifest
new file mode 100644
index 0000000..13dbf08
--- /dev/null
+++ b/app-emulation/amazon-ecr-credential-helper/Manifest
@@ -0,0 +1,2 @@
+DIST amazon-ecr-credential-helper-0.1.0.tar.gz 326639 BLAKE2B 7fdccb48f71fff58300e44f692124ceb254240c34dcbffd2bc751a4480e4c11651c41a0da3e658089ce878bbbc9e17c2fe5b12694f8ea0c6a56df747b7b383b4 SHA512 548467bff91a39e0f43bca38286b84064d1f501cea7418baea571cbd103690448027b479ed7e4eea82b309f28d74ed65d4f26e4cf3ed0dc66b2c68cf7c871cb5
+EBUILD amazon-ecr-credential-helper-0.1.0.ebuild 831 BLAKE2B 9a5be71a4dffed143ed36e5e79317c2cf869e07dc1dcd1731e2675a83d6748e936e98d40a1962be3f2e726da9eb01a54ec3705dc2560cdfca4f6e3f8fa0ede3a SHA512 751b6831c1ef680c43fead4bee45214d67e6286f9f4b2c4e409184dbd153e81a22b87c23a712fb624f07fa0b76e6d0b2d3fa91785b40c3468fdfaa991eadc354
diff --git a/app-emulation/amazon-ecr-credential-helper/amazon-ecr-credential-helper-0.1.0.ebuild b/app-emulation/amazon-ecr-credential-helper/amazon-ecr-credential-helper-0.1.0.ebuild
new file mode 100644
index 0000000..d3ef3a9
--- /dev/null
+++ b/app-emulation/amazon-ecr-credential-helper/amazon-ecr-credential-helper-0.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN=github.com/awslabs/${PN}
+
+EGIT_COMMIT="v${PV}"
+SRC_URI="https://github.com/awslabs/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+# inherit golang-build golang-vcs-snapshot
+inherit golang-base golang-vcs-snapshot
+
+DESCRIPTION="Automatically gets credentials for Amazon ECR on docker push/docker pull"
+HOMEPAGE="https://github.com/awslabs/amazon-ecr-credential-helper"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ ego_pn_check
+ set -- env GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
+ go build -v -work -x ${EGO_BUILD_FLAGS} ${EGO_PN}/ecr-login/cli/docker-credential-ecr-login
+ echo "$@"
+ "$@" || die
+}
+
+src_install() {
+ cd ${EGO_PN}
+ dobin docker-credential-ecr-login
+}
diff --git a/app-emulation/amazon-ecr-credential-helper/metadata.xml b/app-emulation/amazon-ecr-credential-helper/metadata.xml
new file mode 100644
index 0000000..070e23e
--- /dev/null
+++ b/app-emulation/amazon-ecr-credential-helper/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@sattvik.com</email>
+ <name>Daniel Solano Gómez</name>
+ </maintainer>
+</pkgmetadata>