summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/google-benchmark/google-benchmark-9999.ebuild')
-rw-r--r--dev-libs/google-benchmark/google-benchmark-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/google-benchmark/google-benchmark-9999.ebuild b/dev-libs/google-benchmark/google-benchmark-9999.ebuild
new file mode 100644
index 0000000..7149e44
--- /dev/null
+++ b/dev-libs/google-benchmark/google-benchmark-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header:$
+
+EAPI="5"
+
+inherit git-2 cmake-utils flag-o-matic
+
+EGIT_REPO_URI="https://github.com/google/benchmark"
+EGIT_BRANCH="master"
+
+DESCRIPTION="A microbenchmark support library"
+HOMEPAGE="https://github.com/google/benchmark"
+
+LICENSE="Apache-2.0"
+
+SLOT="0"
+
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/protobuf-2.5.0
+ dev-util/cmake
+ >=sys-devel/gcc-4.8.0
+ >=net-misc/curl-7.45.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+KEYWORDS="~amd64"
+
+src_configure()
+{
+# local mycmakeargs=(
+# $(cmake-utils_use cgi BUILD_CGI)
+# )
+ append-cxxflags -std=c++11 -Wno-deprecated-declarations
+ cmake-utils_src_configure
+
+}