summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@gmx.de>2016-05-06 10:13:53 +0200
committerSven Eden <sven.eden@gmx.de>2016-05-06 10:13:53 +0200
commitc45f898350de7ba33e06a30a141c7767307738e2 (patch)
tree8b8edcd3422d1b4c0162132bcc85274173e7f584 /sci-misc/boinc/files
parentnet-libs/telegram-qt-9999.ebuild : Fixed URL (diff)
downloadseden-c45f898350de7ba33e06a30a141c7767307738e2.tar.gz
seden-c45f898350de7ba33e06a30a141c7767307738e2.tar.bz2
seden-c45f898350de7ba33e06a30a141c7767307738e2.zip
sci-misc/boinc : Removed, because I am now proxy maintainer of the in tree boinc.
Diffstat (limited to 'sci-misc/boinc/files')
-rw-r--r--sci-misc/boinc/files/boinc.conf17
-rw-r--r--sci-misc/boinc/files/boinc.init103
-rw-r--r--sci-misc/boinc/files/boinc.service11
3 files changed, 0 insertions, 131 deletions
diff --git a/sci-misc/boinc/files/boinc.conf b/sci-misc/boinc/files/boinc.conf
deleted file mode 100644
index 0fef6ae..0000000
--- a/sci-misc/boinc/files/boinc.conf
+++ /dev/null
@@ -1,17 +0,0 @@
-# Config file for /etc/init.d/boinc
-
-# Owner of BOINC process (must be existing)
-USER="boinc"
-GROUP="boinc"
-
-# Directory with runtime data: Work units, project binaries, user info etc.
-RUNTIMEDIR="/var/lib/boinc"
-
-# Location of the boinc command line binary
-BOINCBIN="/usr/bin/boinc_client"
-
-# Allow remote gui RPC yes or no
-ALLOW_REMOTE_RPC="no"
-
-# nice level
-NICELEVEL="19"
diff --git a/sci-misc/boinc/files/boinc.init b/sci-misc/boinc/files/boinc.init
deleted file mode 100644
index a350e3e..0000000
--- a/sci-misc/boinc/files/boinc.init
+++ /dev/null
@@ -1,103 +0,0 @@
-#!/sbin/runscript
-
-extra_started_commands="attach"
-
-depend() {
- # we can use dns and net, but we can also in most cases live without them
- use dns net ntp-client ntpd
-}
-
-create_work_directory() {
- if [ ! -d "${RUNTIMEDIR}" ]; then
- einfo "Directory ${RUNTIMEDIR} not existing, creating now."
- mkdir "${RUNTIMEDIR}"
- if [ ! -d "${RUNTIMEDIR}" ]; then
- eeror "Directory ${RUNTIMEDIR} could not be created!"
- return 1
- fi
- fi
- if [ ! -e "${RUNTIMEDIR}"/ca-bundle.crt ] ; then
- ln -s /etc/ssl/certs/ca-certificates.crt "${RUNTIMEDIR}"/ca-bundle.crt
- fi
-}
-
-cuda_check() {
- if [ -f /opt/cuda/lib/libcudart.so ]; then
- # symlink wont harm :]
- ln -snf /opt/cuda/lib/libcudart.so "${RUNTIMEDIR}"/libcudart.so
- fi
-}
-
-check_baselayout() {
- if [ "${RC_VERSION:-0}" = "0" ]; then
- eerror "This script cannot be used for baselayout-1."
- return 1
- fi
-}
-
-start() {
- check_baselayout || return 1
- create_work_directory || return 1
- cuda_check
-
- # always ensure proper ownership
- chown -R "${USER}:${GROUP}" "${RUNTIMEDIR}"
-
- if [ ! -f "${RUNTIMEDIR}/lockfile" ]; then
- einfo "File \"${RUNTIMEDIR}/lockfile\" does not exist, assuming first run."
- einfo "You need to setup an account on the BOINC project homepage beforehand!"
- einfo "Go to http://boinc.berkeley.edu/ and locate your project."
- einfo "Then either run /etc/init.d/boinc attach or connect with a gui client"
- einfo "and attach to a project with that."
- echo
- ewarn "Note that for attaching to some project you need your network up and running."
- ewarn "network is needed only for jobs fetching afterwards"
- fi
-
- if [ "${ALLOW_REMOTE_RPC}" = "yes" ]; then
- ARGS="${ARGS} --allow_remote_gui_rpc"
- fi
-
- ebegin "Starting ${SVCNAME}"
- su -m ${USER} -c "nice -n ${NICELEVEL} \"${BOINCBIN}\" ${ARGS} --daemon --dir \"${RUNTIMEDIR}\" --redirectio"
- eend $?
-}
-
-attach() {
- local password url key
-
- einfo "If you cant find your account key just try to obtain it by using:"
- einfo " boinccmd --passwd PASSWORD_FROM_GUI_RPC_AUTH --lookup_account URL EMAIL PASSWORD"
-
- printf " Enter the Project URL: "
- read url
- printf " Enter your Account Key: "
- read key
-
- if ! service_started; then
- "${RC_SERVICE}" start
- fi
-
- password=$(cat "${RUNTIMEDIR}/gui_rpc_auth.cfg")
-
- ebegin "${SVCNAME}: Attaching to project"
- su -m ${USER} -c "boinccmd --passwd \"${password}\" --project_attach ${url} ${key}"
- eend $?
-
- unset password url key
-
- sleep 10
- tail "${RUNTIMEDIR}/stdoutdae.txt"
-}
-
-stop() {
- local password
-
- password=$(cat "${RUNTIMEDIR}/gui_rpc_auth.cfg")
-
- ebegin "Stopping ${SVCNAME}"
- su -m ${USER} -c "boinccmd --passwd \"${password}\" --quit"
- eend $?
-
- unset password
-}
diff --git a/sci-misc/boinc/files/boinc.service b/sci-misc/boinc/files/boinc.service
deleted file mode 100644
index af8edf4..0000000
--- a/sci-misc/boinc/files/boinc.service
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Description=BOINC Daemon
-
-[Service]
-User=boinc
-Group=boinc
-Nice=19
-ExecStart=/usr/bin/boinc_client --dir /var/lib/boinc --redirectio
-
-[Install]
-WantedBy=multi-user.target