summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@gmx.de>2014-11-04 15:22:02 +0100
committerSven Eden <sven.eden@gmx.de>2014-11-04 15:22:02 +0100
commitf123b41b0ccb55f1ab8eaba7dbc4df639097ce07 (patch)
tree082c2c20ba33a5087da7e9ad25fe5e058516e00f /sci-misc/boinc/files
parentdev-util/nvidia-cuda-toolkit-6.5.14-r1.ebuild : Changed to support gcc-4.9 (diff)
downloadseden-f123b41b0ccb55f1ab8eaba7dbc4df639097ce07.tar.gz
seden-f123b41b0ccb55f1ab8eaba7dbc4df639097ce07.tar.bz2
seden-f123b41b0ccb55f1ab8eaba7dbc4df639097ce07.zip
sci-misc/boinc-7.2.42.ebuild : git enabled ebuild to use newest release version.
Diffstat (limited to 'sci-misc/boinc/files')
-rw-r--r--sci-misc/boinc/files/boinc-7.2-fix_subdirs.patch61
-rw-r--r--sci-misc/boinc/files/boinc.conf17
-rw-r--r--sci-misc/boinc/files/boinc.init103
-rw-r--r--sci-misc/boinc/files/boinc.service11
4 files changed, 192 insertions, 0 deletions
diff --git a/sci-misc/boinc/files/boinc-7.2-fix_subdirs.patch b/sci-misc/boinc/files/boinc-7.2-fix_subdirs.patch
new file mode 100644
index 0000000..0502b7e
--- /dev/null
+++ b/sci-misc/boinc/files/boinc-7.2-fix_subdirs.patch
@@ -0,0 +1,61 @@
+ Makefile.am | 14 +++++++-------
+ configure.ac | 5 -----
+ 2 files changed, 7 insertions(+), 12 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 6322db1..45d8b67 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -10,13 +10,13 @@ ACLOCAL_AMFLAGS = -I m4
+
+ if ENABLE_LIBRARIES
+ API_SUBDIRS = api lib
+-if ENABLE_SERVER
+- API_SUBDIRS += zip
+-endif
++#if ENABLE_SERVER
++# API_SUBDIRS += zip
++#endif
+ endif
+
+ if ENABLE_SERVER
+- SERVER_SUBDIRS = db test py sched apps tools vda html
++ SERVER_SUBDIRS = db test py sched apps tools vda
+ ## once contained samples/example_app which breaks out-of-source-tree builds
+ endif
+
+@@ -26,9 +26,9 @@ endif
+
+ if ENABLE_MANAGER
+ CLIENTGUI_SUBDIRS = clientgui locale
+-if BUILD_X11_SCREENSAVER
+- CLIENTGUI_SUBDIRS += clientscr
+-endif
++#if BUILD_X11_SCREENSAVER
++# CLIENTGUI_SUBDIRS += clientscr
++#endif
+ endif
+
+ # ORDER MATTERS below. One must build dependencies FIRST, then things
+diff --git a/configure.ac b/configure.ac
+index 2bef437..5a9e104 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -964,7 +963,6 @@ AC_CONFIG_FILES([
+ db/Makefile
+ doc/Makefile
+ doc/manpages/Makefile
+- html/Makefile
+ lib/Makefile
+ locale/Makefile
+ Makefile
+@@ -994,9 +992,6 @@ AC_CONFIG_FILES([
+ tools/boinc_path_config.py:py/boinc_path_config.py.in
+ tools/Makefile
+ vda/Makefile
+- zip/Makefile
+- zip/zip/Makefile
+- zip/unzip/Makefile
+ m4/Makefile
+ ])
+
diff --git a/sci-misc/boinc/files/boinc.conf b/sci-misc/boinc/files/boinc.conf
new file mode 100644
index 0000000..0fef6ae
--- /dev/null
+++ b/sci-misc/boinc/files/boinc.conf
@@ -0,0 +1,17 @@
+# Config file for /etc/init.d/boinc
+
+# Owner of BOINC process (must be existing)
+USER="boinc"
+GROUP="boinc"
+
+# Directory with runtime data: Work units, project binaries, user info etc.
+RUNTIMEDIR="/var/lib/boinc"
+
+# Location of the boinc command line binary
+BOINCBIN="/usr/bin/boinc_client"
+
+# Allow remote gui RPC yes or no
+ALLOW_REMOTE_RPC="no"
+
+# nice level
+NICELEVEL="19"
diff --git a/sci-misc/boinc/files/boinc.init b/sci-misc/boinc/files/boinc.init
new file mode 100644
index 0000000..a350e3e
--- /dev/null
+++ b/sci-misc/boinc/files/boinc.init
@@ -0,0 +1,103 @@
+#!/sbin/runscript
+
+extra_started_commands="attach"
+
+depend() {
+ # we can use dns and net, but we can also in most cases live without them
+ use dns net ntp-client ntpd
+}
+
+create_work_directory() {
+ if [ ! -d "${RUNTIMEDIR}" ]; then
+ einfo "Directory ${RUNTIMEDIR} not existing, creating now."
+ mkdir "${RUNTIMEDIR}"
+ if [ ! -d "${RUNTIMEDIR}" ]; then
+ eeror "Directory ${RUNTIMEDIR} could not be created!"
+ return 1
+ fi
+ fi
+ if [ ! -e "${RUNTIMEDIR}"/ca-bundle.crt ] ; then
+ ln -s /etc/ssl/certs/ca-certificates.crt "${RUNTIMEDIR}"/ca-bundle.crt
+ fi
+}
+
+cuda_check() {
+ if [ -f /opt/cuda/lib/libcudart.so ]; then
+ # symlink wont harm :]
+ ln -snf /opt/cuda/lib/libcudart.so "${RUNTIMEDIR}"/libcudart.so
+ fi
+}
+
+check_baselayout() {
+ if [ "${RC_VERSION:-0}" = "0" ]; then
+ eerror "This script cannot be used for baselayout-1."
+ return 1
+ fi
+}
+
+start() {
+ check_baselayout || return 1
+ create_work_directory || return 1
+ cuda_check
+
+ # always ensure proper ownership
+ chown -R "${USER}:${GROUP}" "${RUNTIMEDIR}"
+
+ if [ ! -f "${RUNTIMEDIR}/lockfile" ]; then
+ einfo "File \"${RUNTIMEDIR}/lockfile\" does not exist, assuming first run."
+ einfo "You need to setup an account on the BOINC project homepage beforehand!"
+ einfo "Go to http://boinc.berkeley.edu/ and locate your project."
+ einfo "Then either run /etc/init.d/boinc attach or connect with a gui client"
+ einfo "and attach to a project with that."
+ echo
+ ewarn "Note that for attaching to some project you need your network up and running."
+ ewarn "network is needed only for jobs fetching afterwards"
+ fi
+
+ if [ "${ALLOW_REMOTE_RPC}" = "yes" ]; then
+ ARGS="${ARGS} --allow_remote_gui_rpc"
+ fi
+
+ ebegin "Starting ${SVCNAME}"
+ su -m ${USER} -c "nice -n ${NICELEVEL} \"${BOINCBIN}\" ${ARGS} --daemon --dir \"${RUNTIMEDIR}\" --redirectio"
+ eend $?
+}
+
+attach() {
+ local password url key
+
+ einfo "If you cant find your account key just try to obtain it by using:"
+ einfo " boinccmd --passwd PASSWORD_FROM_GUI_RPC_AUTH --lookup_account URL EMAIL PASSWORD"
+
+ printf " Enter the Project URL: "
+ read url
+ printf " Enter your Account Key: "
+ read key
+
+ if ! service_started; then
+ "${RC_SERVICE}" start
+ fi
+
+ password=$(cat "${RUNTIMEDIR}/gui_rpc_auth.cfg")
+
+ ebegin "${SVCNAME}: Attaching to project"
+ su -m ${USER} -c "boinccmd --passwd \"${password}\" --project_attach ${url} ${key}"
+ eend $?
+
+ unset password url key
+
+ sleep 10
+ tail "${RUNTIMEDIR}/stdoutdae.txt"
+}
+
+stop() {
+ local password
+
+ password=$(cat "${RUNTIMEDIR}/gui_rpc_auth.cfg")
+
+ ebegin "Stopping ${SVCNAME}"
+ su -m ${USER} -c "boinccmd --passwd \"${password}\" --quit"
+ eend $?
+
+ unset password
+}
diff --git a/sci-misc/boinc/files/boinc.service b/sci-misc/boinc/files/boinc.service
new file mode 100644
index 0000000..af8edf4
--- /dev/null
+++ b/sci-misc/boinc/files/boinc.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=BOINC Daemon
+
+[Service]
+User=boinc
+Group=boinc
+Nice=19
+ExecStart=/usr/bin/boinc_client --dir /var/lib/boinc --redirectio
+
+[Install]
+WantedBy=multi-user.target