summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNoel Darlow <mail@mcgruff.plus.com>2012-06-09 02:57:39 +0100
committerNoel Darlow <mail@mcgruff.plus.com>2012-06-09 02:57:39 +0100
commit91181275d6e5801c39c34730c249531172e9b046 (patch)
treef58ead0238d36cdf0f601c97bf0b007409bb08f0
parentdd (diff)
downloadunderlay-91181275d6e5801c39c34730c249531172e9b046.tar.gz
underlay-91181275d6e5801c39c34730c249531172e9b046.tar.bz2
underlay-91181275d6e5801c39c34730c249531172e9b046.zip
dddddd
-rw-r--r--app-admin/gentool/Manifest2
-rw-r--r--app-admin/gentool/gentool-0.2.7.ebuild20
2 files changed, 16 insertions, 6 deletions
diff --git a/app-admin/gentool/Manifest b/app-admin/gentool/Manifest
index 86db18b..5ee313b 100644
--- a/app-admin/gentool/Manifest
+++ b/app-admin/gentool/Manifest
@@ -1,4 +1,4 @@
DIST gentool-0.2.7.tar.bz2 8572 RMD160 6561fb66da894f3a75435b075e20a4cf5803c543 SHA1 087c4f4cb028728d7a55a7b72ee82186966d37e4 SHA256 7ed88da2a563ccc7e925b7adfc33484d0df5284380e4f750fd06aadf0f7ec429
-EBUILD gentool-0.2.7.ebuild 907 RMD160 22c73b10d41138e558d529a78d6dbcdf2f89c953 SHA1 1b37cea0541716c68b07ac108b40f15a89671581 SHA256 072ec1e0766624fbaf379ac39d4c79d4af76d76665491670ab3dd208bdbbc529
+EBUILD gentool-0.2.7.ebuild 1035 RMD160 4fbc505fbdd8d37ac282c361233c59d6b5178f7d SHA1 7f67b8f366d183f013f77cd04d1e2ecf6a3d748d SHA256 c2d9501bd1eac8727eb203f562861abe872e9f97de706eab1f68365c83884a92
MISC ChangeLog 0 RMD160 9c1185a5c5e9fc54612808977ee8f548b2258d31 SHA1 da39a3ee5e6b4b0d3255bfef95601890afd80709 SHA256 e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
MISC metadata.xml 513 RMD160 5ccacd7985a83578b1b02f37e5321fce4c75f73f SHA1 891e34ce89792243996e4c8319d1508964b096df SHA256 503e044c2881c5f53de73bcff9fd25d8c097182434c636e2614538d0f568bc53
diff --git a/app-admin/gentool/gentool-0.2.7.ebuild b/app-admin/gentool/gentool-0.2.7.ebuild
index e603cd4..c7dc3b8 100644
--- a/app-admin/gentool/gentool-0.2.7.ebuild
+++ b/app-admin/gentool/gentool-0.2.7.ebuild
@@ -25,19 +25,29 @@ RDEPEND=">=app-misc/bashfun-0.1.4
src_install() {
dodir /opt/bin
dosym /opt/gentool/bin/gentool.sh /opt/bin/gentool
+
insinto '/opt'
- doins -r "${S}/opt/gentool"
- dodir '/etc/gentool'
+ insopts -m0755
+ doins -r "${S}/opt/gentool/bin"
+
+ insinto '/opt'
+ insopts -m0644
+ doins -r "${S}/opt/gentool/docs"
+
+ insinto '/opt'
+ insopts -m0644
+ doins -r "${S}/opt/gentool/lib"
+
+ dodir '/etc/gentool'
insinto '/etc/gentool'
+ insopts -m0644
doins "${S}/etc/gentool/config.sh"
+
doenvd "${S}/etc/env.d/99gentool-env"
- fperms +x /opt/gentool/bin/*
- fperms +x /opt/bin/gentool
}
pkg_postinst() {
elog
elog 'you may want to edit /etc/gentool/config.sh now - just follow instructions in the file'
elog
- elog $D
}