summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVance M. Allen <vma_gentoo@vmacs.us>2017-11-13 18:50:54 -0700
committerVance M. Allen <vma_gentoo@vmacs.us>2017-11-13 18:50:54 -0700
commit1eac56d88be4d3bf39fdd60c02c511b415243653 (patch)
treefb69033258b6f87e3fda56901987ec50400fb8ed
parentAdd support for net-analyzer/fail2ban-0.10.0 (diff)
downloadvmacs-1eac56d88be4d3bf39fdd60c02c511b415243653.tar.gz
vmacs-1eac56d88be4d3bf39fdd60c02c511b415243653.tar.bz2
vmacs-1eac56d88be4d3bf39fdd60c02c511b415243653.zip
Remove fail2ban-0.10.0, not working correctly
-rw-r--r--net-analyzer/fail2ban/Manifest3
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.10.0.ebuild104
-rw-r--r--net-analyzer/fail2ban/metadata.xml11
3 files changed, 0 insertions, 118 deletions
diff --git a/net-analyzer/fail2ban/Manifest b/net-analyzer/fail2ban/Manifest
deleted file mode 100644
index a77023e..0000000
--- a/net-analyzer/fail2ban/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST fail2ban-0.10.0.tar.gz 459855 SHA256 2c182290ab093b171c705a72881bf7b5927882f387a49d291aa7c70afe80f03e SHA512 21c3da677f47f762ac360f47e5df5ee364f0676710e332f50bf24e2a84f0b1a89cf85dd3cc3a9f32cd610d7d96cb657be25e112a1dc3f456f35eeb236e2ea810 WHIRLPOOL b1e75432bd4ed017c061f2ba1a4675796b7f1e1ab347f7646885f035540b55e66dfadd39fa544c5904bc508852674380cd15d15f0ab0ed509846640a1b22f1a3
-EBUILD fail2ban-0.10.0.ebuild 3177 SHA256 5938c7ca0b898159794926e75f2175a63666a18aef5df0d507636f38058d9af9 SHA512 b0f25b9e4401d981ff757bf0784b957d5731e4bfd3c434a876569848d3c4b84a96f748d195d79c68f1a94b3eedc577454ede6d4d7c5479dfe233daf2631c2bbe WHIRLPOOL 5d168f28beb5cfbc9f7fed6af5304f1d6a5f1dbe5cdfa5bea41c0bb917dc1fefd3f654dfd4b1b6591746bebb93ed75f598d013aa370c3d623c12c0d729973162
-MISC metadata.xml 372 SHA256 746d170f99e2455a543c83a3cf014d6f9a773f28fc6085e7a45f1027db52a157 SHA512 4d5710e2fb4a7c353ca6bd3203bceef57d4d004367993dc1044800ee8713a3f4697fe8ba3472a73ecd015503656dfb7cd68d674c99188ce5702769cfeaf06b25 WHIRLPOOL a07677d213d65611156795231fdc0e15d15e7d57d0bcb72fb2b102ebf9c42f43a22f025eace591242e8b824736a169909a9fa79480aa6c5997712b7324e89df4
diff --git a/net-analyzer/fail2ban/fail2ban-0.10.0.ebuild b/net-analyzer/fail2ban/fail2ban-0.10.0.ebuild
deleted file mode 100644
index 416c743..0000000
--- a/net-analyzer/fail2ban/fail2ban-0.10.0.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
-DISTUTILS_SINGLE_IMPL=1
-
-inherit distutils-r1 eutils systemd vcs-snapshot
-
-DESCRIPTION="scans log files and bans IPs that show malicious signs"
-HOMEPAGE="http://www.fail2ban.org/"
-SRC_URI="https://github.com/${PN}/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="selinux systemd"
-
-# TODO support ipfw and ipfilter
-RDEPEND="
- kernel_linux? ( net-firewall/iptables )
- kernel_FreeBSD? ( sys-freebsd/freebsd-pf )
- net-misc/whois
- virtual/logger
- virtual/mta
- selinux? ( sec-policy/selinux-fail2ban )
- systemd? ( $(python_gen_cond_dep '|| (
- dev-python/python-systemd[${PYTHON_USEDEP}]
- sys-apps/systemd[python(-),${PYTHON_USEDEP}]
- )' 'python*' ) )
-"
-
-REQUIRED_USE="systemd? ( !python_single_target_pypy )"
-
-DOCS=( ChangeLog DEVELOP README.md THANKS TODO doc/run-rootless.txt )
-
-python_prepare_all() {
- # Replace /var/run with /run, but not in the top source directory
- find . -mindepth 2 -type f -exec \
- sed -i -e 's|/var\(/run/fail2ban\)|\1|g' {} + || die
-
- sed -i -e 's|runscript|openrc-run|g' files/gentoo-initd || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${PYTHON}" "bin/${PN}-testcases" || die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- rm -rf "${D}"/usr/share/doc/${PN} "${D}"/run || die
-
- # not FILESDIR
- newconfd files/gentoo-confd ${PN}
- newinitd files/gentoo-initd ${PN}
- systemd_dounit files/${PN}.service
- systemd_dotmpfilesd files/${PN}-tmpfiles.conf
- doman man/*.{1,5}
-
- # Use INSTALL_MASK if you do not want to touch /etc/logrotate.d.
- # See http://thread.gmane.org/gmane.linux.gentoo.devel/35675
- insinto /etc/logrotate.d
- newins files/${PN}-logrotate ${PN}
-}
-
-pkg_preinst() {
- has_version "<${CATEGORY}/${PN}-0.7"
- previous_less_than_0_7=$?
-}
-
-pkg_postinst() {
- if [[ $previous_less_than_0_7 = 0 ]] ; then
- elog
- elog "Configuration files are now in /etc/fail2ban/"
- elog "You probably have to manually update your configuration"
- elog "files before restarting Fail2ban!"
- elog
- elog "Fail2ban is not installed under /usr/lib anymore. The"
- elog "new location is under /usr/share."
- elog
- elog "You are upgrading from version 0.6.x, please see:"
- elog "http://www.fail2ban.org/wiki/index.php/HOWTO_Upgrade_from_0.6_to_0.8"
- fi
- if ! has_version ${CATEGORY}/${PN}; then
- if ! has_version dev-python/pyinotify && ! has_version app-admin/gamin; then
- elog "For most jail.conf configurations, it is recommended you install either"
- elog "dev-python/pyinotify or app-admin/gamin (in order of preference)"
- elog "to control how log file modifications are detected"
- fi
-
- if ! has_version dev-lang/python[sqlite]; then
- elog "If you want to use ${PN}'s persistent database, then reinstall"
- elog "dev-lang/python with USE=sqlite"
- fi
-
- if has_version sys-apps/systemd[-python]; then
- elog "If you want to track logins through sys-apps/systemd's"
- elog "journal backend, then reinstall sys-apps/systemd with USE=python"
- fi
- fi
-}
diff --git a/net-analyzer/fail2ban/metadata.xml b/net-analyzer/fail2ban/metadata.xml
deleted file mode 100644
index ece130a..0000000
--- a/net-analyzer/fail2ban/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>netmon@gentoo.org</email>
- <name>Gentoo network monitoring and analysis project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">fail2ban/fail2ban</remote-id>
- </upstream>
-</pkgmetadata>